Green-sell.info

Новые технологии
1 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Лог выражение в excel

Логические функции Excel

Подобного рода функциями служат такие, которые возвращают результат после проверки данных, который всегда представляет «ИСТИНА» либо «ЛОЖЬ», что означает – результат удовлетворяет заданному условию либо не удовлетворяет, соответственно.

Прежде чем перейти к рассмотрению описанных функций, ознакомьтесь со статьей нашего сайта Условия сравнения чисел и строк в Excel.

В описаниях синтаксиса функций их аргументы, которые заключены в квадратные скобки «[]», являются необязательными.

Будут рассмотрены следующие функции:

Функция ИСТИНА

Не принимает никаких аргументов и просто возвращает логическое значение «ИСТИНА».

Синтаксис: =ИСТИНА()

Функция ЛОЖЬ

Аналогична функции ИСТИНА, за исключением то, что возвращает противоположный результат ЛОЖЬ.

Синтаксис: =ЛОЖЬ()

Функция И

Возвращает логическое значение ИСТИНА, если все аргументы функции вернули истинное значение. Если хотя бы один аргумент возвращает значение ЛОЖЬ, то вся функция вернет данное значение.

В виде аргументов должны приниматься условия либо ссылки на ячейки, возвращающие логические значения. Количество аргументов не может превышать 255. Первый аргумент является обязательным.

Рассмотрим таблицу истинности данной функции:

Синтаксис: =И(Логическое_значение1; [Логическое_значение1];…)

Пример использования:

В первом примере видно, что все аргументы возвращают истинное значение, следовательно, и сама функция вернет истинный результат.

Во втором примере функция никогда не вернет значение ИСТИНА, т.к. условие ее второго аргумента заранее неравно.

Функция ИЛИ

Возвращает логическое значение ИСТИНА, если хотя бы один аргумент функции вернет истинное значение.

В виде аргументов принимаются условия либо ссылки на ячейки, возвращающие логические значения. Количество аргументов не может превышать 255. Первый аргумент является обязательным.

Таблица истинности функции ИЛИ:

Синтаксис: =ИЛИ(Логическое_значение1; [Логическое_значение2];…)

В качестве примера, рассмотрите примеры функции И, все они вернут результат ИСТИНА, т.к. первый аргумент является истинным.

Функция НЕ

Принимает в виде аргумента всего одно логическое значение и меняет его на противоположное, т.е. значение ИСТИНА она изменит на ЛОЖЬ и наоборот.

Таблица истинности функции И с применением функции НЕ:

Таблица истинности функции ИЛИ с применением функции НЕ:

Синтаксис: =НЕ(логическое_значение)

Функция ЕСЛИ

Является одной из самых полезных, имеющихся в Excel, функций. Она проверяет результат переданного ей логического выражения и возвращает результаты в зависимости от того истинно он или ложно.

Синтаксис:

Примеры использования функции:

Рассмотрим первый простой пример, чтобы понять, как функция работает.

Умышлено в первый аргумент функции вставить функцию ИСТИНА. В результате проверки, будет возвращен 2 аргумент (значение_если_истина), 3 аргумент будет опущен.

Теперь приведем пример использования вложенности одной функции ЕСЛИ в другую. Такой подход может понадобиться, когда при выполнении (или невыполнении) одного условия требуется дополнительная проверка.

Имеются банковские карточки с номерами, начинающимися с первых четырех цифр, которые являются идентификатором вида карты:

Используем нашу функцию для определения типа карты.

Функция, применяемая в данном примере, выглядит так:

=ЕСЛИ( ЛЕВСИМВ(A2;4)=»1111″ ; «Visa» ;ЕСЛИ( ЛЕВСИМВ(A2;4)=»2222″ ; «Master Card» ;»карта не определена»))

Помимо самой рассматриваем функции, в примере используется текстовая функция ЛЕВСИМВ, которая возвращает часть текста из строки, начиная с левого края, в количестве символов, заданном вторым ее аргументом. С ее помощью мы проверяем, являются ли они равными строке «1111», если да, возвращаем результат «Visa», если нет, то выполняем вложенную функцию ЕСЛИ.

Подобным образом можно достичь значительной вложенности и организовывать сложные проверки.

Функция ЕСЛИОШИБКА

Предназначена для проверки возврата выражением ошибки. Если ошибка обнаружена, то она возвращает значение второго аргумента, иначе первого.

Функция принимает 2 аргумента, все они являются обязательными.

Синтаксис: =ЕСЛИОШИБКА(значение;значение_если_ошибка)

Пример использования функции:

В приведенном примере видно, что выражение в первом аргументе возвращает ошибку деления на ноль, но так как оно вложено в нашу функцию, то ошибка перехватывается и подменяется вторым аргументов, а именно строкой «Делить на ноль нельзя», которую мы ввели самостоятельно. Вместо данной строки могли бы быть другие функции, все зависит от поставленной перед Вами задачи.

Логические функции в программе Microsoft Excel

Среди множества различных выражений, которые применяются при работе с Microsoft Excel, следует выделить логические функции. Их применяют для указания выполнения различных условий в формулах. При этом, если сами условия могут быть довольно разнообразными, то результат логических функций может принимать всего два значения: условие выполнено (ИСТИНА) и условие не выполнено (ЛОЖЬ). Давайте подробнее разберемся, что представляют собой логические функции в Экселе.

Основные операторы

Существует несколько операторов логических функций. Среди основных следует выделить такие:

Читать еще:  Код символа переноса строки в excel

Существуют и менее распространенные логические функции.

У каждого из вышеуказанных операторов, кроме первых двух, имеются аргументы. Аргументами могут выступать, как конкретные числа или текст, так и ссылки, указывающие адрес ячеек с данными.

Функции ИСТИНА и ЛОЖЬ

Оператор ИСТИНА принимает только определенное заданное значение. У данной функции отсутствуют аргументы, и, как правило, она практически всегда является составной частью более сложных выражений.

Оператор ЛОЖЬ, наоборот, принимает любое значение, которое не является истиной. Точно так же эта функция не имеет аргументов и входит в более сложные выражения.

Функции И и ИЛИ

Функция И является связующим звеном между несколькими условиями. Только при выполнении всех условий, которые связывает данная функция, она возвращает значение ИСТИНА. Если хотя бы один аргумент сообщает значение ЛОЖЬ, то и оператор И в целом возвращает это же значение. Общий вид данной функции: =И(лог_значение1;лог_значение2;…) . Функция может включать в себя от 1 до 255 аргументов.

Функция ИЛИ, наоборот, возвращает значение ИСТИНА даже в том случае, если только один из аргументов отвечает условиям, а все остальные ложные. Её шаблон имеет следующий вид: =И(лог_значение1;лог_значение2;…) . Как и предыдущая функция, оператор ИЛИ может включать в себя от 1 до 255 условий.

Функция НЕ

В отличие от двух предыдущих операторов, функция НЕ имеет всего лишь один аргумент. Она меняет значение выражения с ИСТИНА на ЛОЖЬ в пространстве указанного аргумента. Общий синтаксис формулы выглядит следующим образом: =НЕ(лог_значение) .

Функции ЕСЛИ и ЕСЛИОШИБКА

Для более сложных конструкций используется функция ЕСЛИ. Данный оператор указывает, какое именно значение является ИСТИНА, а какое ЛОЖЬ. Его общий шаблон выглядит следующим образом: =ЕСЛИ(логическое_выражение;значение_если_истина;значение_если-ложь) . Таким образом, если условие соблюдается, то в ячейку, содержащую данную функцию, заполняют заранее указанные данные. Если условие не соблюдается, то ячейка заполняется другими данными, указанными в третьем по счету аргументе функции.

Оператор ЕСЛИОШИБКА, в случае если аргумент является истиной, возвращает в ячейку его собственное значение. Но, если аргумент ошибочный, тогда в ячейку возвращается то значение, которое указывает пользователь. Синтаксис данной функции, содержащей всего два аргумента, выглядит следующем образом: =ЕСЛИОШИБКА(значение;значение_если_ошибка) .

Функции ЕОШИБКА и ЕПУСТО

Функция ЕОШИБКА проверяет, не содержит ли определенная ячейка или диапазон ячеек ошибочные значения. Под ошибочными значениями понимаются следующие:

В зависимости от того ошибочный аргумент или нет, оператор сообщает значение ИСТИНА или ЛОЖЬ. Синтаксис данной функции следующий: = ЕОШИБКА(значение) . В роли аргумента выступает исключительно ссылка на ячейку или на массив ячеек.

Оператор ЕПУСТО делает проверку ячейки на то, пустая ли она или содержит значения. Если ячейка пустая, функция сообщает значение ИСТИНА, если ячейка содержит данные – ЛОЖЬ. Синтаксис этого оператора имеет такой вид: =ЕПУСТО(значение) . Так же, как и в предыдущем случае, аргументом выступает ссылка на ячейку или массив.

Пример применения функций

Теперь давайте рассмотрим применение некоторых из вышеперечисленных функций на конкретном примере.

Имеем список работников предприятия с положенными им заработными платами. Но, кроме того, всем работникам положена премия. Обычная премия составляет 700 рублей. Но пенсионерам и женщинам положена повышенная премия в размере 1000 рублей. Исключение составляют работники, по различным причинам проработавшие в данном месяце менее 18 дней. Им в любом случае положена только обычная премия в размере 700 рублей.

Попробуем составить формулу. Итак, у нас существует два условия, при исполнении которых положена премия в 1000 рублей – это достижение пенсионного возраста или принадлежность работника к женскому полу. При этом, к пенсионерам отнесем всех тех, кто родился ранее 1957 года. В нашем случае для первой строчки таблицы формула примет такой вид: =ЕСЛИ(ИЛИ(C4 . Но, не забываем, что обязательным условием получения повышенной премии является отработка 18 дней и более. Чтобы внедрить данное условие в нашу формулу, применим функцию НЕ: =ЕСЛИ(ИЛИ(C4 .

Для того, чтобы скопировать данную функцию в ячейки столбца таблицы, где указана величина премии, становимся курсором в нижний правый угол ячейки, в которой уже имеется формула. Появляется маркер заполнения. Просто перетягиваем его вниз до конца таблицы.

Таким образом, мы получили таблицу с информацией о величине премии для каждого работника предприятия в отдельности.

Как видим, логические функции являются очень удобным инструментом для проведения расчетов в программе Microsoft Excel. Используя сложные функции, можно задавать несколько условий одновременно и получать выводимый результат в зависимости от того, выполнены эти условия или нет. Применение подобных формул способно автоматизировать целый ряд действий, что способствует экономии времени пользователя.

Читать еще:  Ошибка перенаправления команды приложению excel

Отблагодарите автора, поделитесь статьей в социальных сетях.

Функция ЕСЛИ

В этом курсе:

Функция ЕСЛИ — одна из самых популярных функций в Excel. Она позволяет выполнять логические сравнения значений и ожидаемых результатов.

Поэтому у функции ЕСЛИ возможны два результата. Первый результат возвращается в случае, если сравнение истинно, второй — если сравнение ложно.

Например, функция =ЕСЛИ(C2=»Да»;1;2) означает следующее: ЕСЛИ(С2=»Да», то вернуть 1, в противном случае вернуть 2).

Функция ЕСЛИ, одна из логических функций, служит для возвращения разных значений в зависимости от того, соблюдается ли условие.

ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь])

Условие, которое нужно проверить.

Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

Простые примеры функции ЕСЛИ

    В примере выше ячейка D2 содержит формулу: ЕСЛИ(C2 = Да, то вернуть 1, в противном случае вернуть 2)

      В этом примере ячейка D2 содержит формулу: ЕСЛИ(C2 = 1, то вернуть текст «Да», в противном случае вернуть текст «Нет»). Как видите, функцию ЕСЛИ можно использовать для сравнения и текста, и значений. А еще с ее помощью можно оценивать ошибки. Вы можете не только проверять, равно ли одно значение другому, возвращая один результат, но и использовать математические операторы и выполнять дополнительные вычисления в зависимости от условий. Для выполнения нескольких сравнений можно использовать несколько вложенных функций ЕСЛИ.

      B2;»Превышение бюджета»,»В пределах бюджета»)» xmlns_AntiXSS=»urn:AntiXSSExtensions» />

        =ЕСЛИ(C2>B2;»Превышение бюджета»;»В пределах бюджета»)

        В примере выше функция ЕСЛИ в ячейке D2 означает: ЕСЛИ(C2 больше B2, то вернуть текст «Превышение бюджета», в противном случае вернуть текст «В пределах бюджета»)

        B2;C2-B2;»»)» xmlns_AntiXSS=»urn:AntiXSSExtensions» />

          На рисунке выше мы возвращаем не текст, а результат математического вычисления. Формула в ячейке E2 означает: ЕСЛИ(значение «Фактические» больше значения «Плановые», то вычесть сумму «Плановые» из суммы «Фактические», в противном случае ничего не возвращать).

            В этом примере формула в ячейке F7 означает: ЕСЛИ(E7 = «Да», то вычислить общую сумму в ячейке F5 и умножить на 8,25 %, в противном случае налога с продажи нет, поэтому вернуть 0)

            Примечание: Если вы используете текст в формулах, заключайте его в кавычки (пример: «Текст»). Единственное исключение — слова ИСТИНА и ЛОЖЬ, которые Excel распознает автоматически.

            Microsoft Excel

            трюки • приёмы • решения

            Как в Excel применять функцию ЕСЛИ()

            Функция ЕСЛИ() является одним из самых мощных инструментов в мире функций. Если вы сумеете освоить ее в работе, вы перейдете на новый уровень создания формул.

            Давайте начнем с простейшей возможности использования формулы. Синтаксис: ЕСЛИ (лог_выражение; значение_если истина), где лог_выражение — логическое выражение, то есть выражение возвращающее значение ИСТИНА или ЛОЖЬ (или эквивалентные численные значения: 0, если ЛОЖЬ, и любое положительное значение — ИСТИНА, и где значение_если истина — значение, возвращаемое функцией, в случае если лог_выражение имеет значение ИСТИНА.

            Например, разберем следующую формулу: =ЕСЛИ(A1>1000;»много») . Логическое выражение А1>100 0 используется для проверки. Допустим, вы добавите данную формулу в ячейку В1. Если логическое выражение является истинным (оно является таковым, когда число в A1 больше 1000), функция возвращает значение «много», и именно это вы увидите в ячейке В1 (в случае если А1 меньше 1000, вы увидите значение ЛОЖЬ).

            Другое простое применение функции — проверка для вывода предупреждений. Например, если у вас имеется книга с результатами увеличения продаж различных товаров в процентах. Будет полезно отметить определенным образом товары с уменьшившимися продажами. Базовая формула для такой отметки представляет собой следующее: =ЕСЛИ(ячейка .

            Здесь ячейка — адрес ячейки для проверки, а отметка — определенного рода текст для вывода на экран для указания на отрицательное значение. Вот пример: =ЕСЛИ(В1 .

            Немного более улучшенная версия отметки, в которой она будет зависеть от величины отрицательного значения, выглядит так: =ПОВТОР(» . Это выражение умножает процентное значение на 100 (минус указан, для того чтобы сделать значение положительным) и затем использует результат для указания количества знаков для вывода. Вот итоговая формула: =ЕСЛИ(В1 . Рис. 4.15 показывает, как это выглядит на практике.

            Рис. 4.15. Пример использования функции ЕСЛИ()

            Обработка ложного результата

            Как вы можете видеть на рис. 4.15, если в функции ЕСЛИ() логическое выражение принимает отрицательное значение, функция возвращает ЛОЖЬ в качестве результата. Это не является критическим недостатком, однако делает рабочие листы как бы «тяжелее», чем если бы в результате возвращалась, например, пустая строка.

            Читать еще:  Двойное если в excel

            Для того чтобы сделать это, вам необходимо использовать расширенный синтаксис функции: ЕСЛИ(лог_выражение; значение_если_истина; значение_если_ложь). Первые два аргумента мы с вами уже знаем, а последний аргумент значение_если_ложь задает значение для возврата функции ЕСЛИ(), когда результат вычисления лог_выражения является ложным.

            Например, рассмотрим следующую формулу: =ЕСЛИ(A1>1000;»много»;»мало») . Если на этот раз ячейка A1 содержит число, меньшее или равное 1000, формула выведет строку «мало». Для примера с отметкой отрицательных объемов продаж (см. выше рис. 4.15) необходимо использовать следующую формулу: =ЕСЛИ(B1 .

            Рис. 4.16. Обработка ложного результата

            Как вы можете судить по рис. 4.16, рабочий лист теперь выглядит гораздо лучше.

            Предотвращение деления на ноль

            Как мы уже указывали ранее, функция возвращает ошибку #ДЕЛ/0!, если формула пытается поделить какое-то значение на 0. Для устранения даже возможности совершения такой ошибки вы можете воспользоваться функцией ЕСЛИ() для проверки деления.

            Например, простейшее вычисление процента валовой прибыли по формуле (Доходы — Расходы)/Доходы. Для уверенности в том, что значение Доходы не равно нулю, используйте следующую формулу (предполагается, что вместо слов Доходы и Расходы будут подставлены необходимые значения): =ЕСЛИ(Доходы <> 0; (Доходы — Расходы)/Доходы; «Доходы равны 0!») . Если логическое выражение Доходы <> 0 верно, значит, произойдет вычисление по формуле. В противном случае функция вернет предупреждающее сообщение вместо ошибки.

            Важными задачами учебного курса в школе являются развитие у учащихся основных мыслительных операций (анализ, синтез, сравнение, обобщение), нормализация взаимосвязи их деятельности с речью, формирование приемов умственной работы: анализ исходных данных, планирование деятельности, осуществление поэтапного и итогового самоконтроля, для чего используется поурочное планирование процесса обучения. Большое значение придается умению рассказывать о выполненной работе с правильным употреблением соответствующей терминологии и установлением логических связей в излагаемом материале.

            Excel: Функция ЕСЛИ

            Функция Если является одной из самых полезных функций в Excel. Она позволяет получать разные значения ячейки в зависимости от выполнения какого-либо условия, а также находить ошибки, уникальные значения в списке, использовать многократные проверки на выполнение условий и многое другое.

            Функция Если проверяет значение логического выражения и возвращает результаты в зависимости от того, истинно оно или ложно.

            Аргументы функции Если

            Если (лог_выражение; [значение_если_истина]; [значение_если_ложь])

            1. Лог_выражение — логическое выражение

            Логические выражения используются для записи условий, в которых сравниваются числа, функции, формулы, текстовые значения. Логическое выражение может принимать одно из двух значений — Истина или Ложь.

            Например, «A10=100» — логическое выражение; если значение в ячейке A10 равно 100, это выражение принимает значение Истина, в противном случае — значение Ложь.
            В этом аргументе может использоваться любой оператор сравнения .

            • > больше
            • = больше или равно
            • не равно
            1. Значение_если_истина — значение, которое помещается в ячейку (возвращается), если лог_выражение соответствует значению Истина.

            Значение может быть числом, текстом, формулой или ссылкой на ячейку.

            1. Значение_если_ложь — значение, которое возвращается, если лог_выражение соответствует значению Ложь.

            Значение может быть числом, текстом, формулой или ссылкой на ячейку.

            Обязателен только первый аргумент (логическое выражение). Если опустить второй и третий аргумент, то вместо заданных нами значений будут выводиться значения «Истина» или «Ложь» в зависимости от истинности логического выражения.

            Примеры:

            Если значение в ячейке А1 больше 5, формула возвращает значение 10, в противном случае — 20:

            2. Если (А1>=3 ; «Зачет сдал» ; «Зачет не сдал»)

            Если в ячейке А1 оценка больше или равна 3, то зачет сдан, в противном случае – нет.

            3. =Если (А1=«оплачено»; В1; 0)

            Эта формула возвращает значение из ячейки В1, если ячейка А1 содержит слово «оплачено», и 0, если в ней находится любое другое значение. Совпадение между сравниваемыми текстовыми значениями должно быть точным, но без учета регистра.

            Для создания более сложных проверок в качестве аргументов можно использовать функции Если , вложенные друг в друга.
            В Excel версий до 2003 включительно — до 7 вложений;
            вExcel версии 2007 — до 64 вложений;
            в Excel версии 2010 — до 128 вложений.

            Понравилось? Поделись с друзьями

            Семинары. Вебинары. Конференции

            Актуальные темы. Лучшие лекторы Москвы и РФ. Сертификаты ИПБР. Более 30 тематик в месяц.

            Ссылка на основную публикацию
            ВсеИнструменты
            Adblock
            detector