Green-sell.info

Новые технологии
1 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Лог выражение в excel это

Функция ЕСЛИ

Возвращает одно значение, если заданное условие при вычислении дает значение ИСТИНА, и другое значение, если ЛОЖЬ.

Функция ЕСЛИ используется при проверке условий для значений и формул.

Лог_выражение — это любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. Например, A10=100 — это логическое выражение; если значение в ячейке A10 равно 100, то выражение принимает значение ИСТИНА. В противном случае — ЛОЖЬ. Этот аргумент может быть использован в любом операторе сравнения.

Значение_если_истина — это значение, которое возвращается, если лог_выражение равно ИСТИНА. Например, если этот аргумент — строка «В пределах бюджета» и лог_выражение равно ИСТИНА, тогда функция ЕСЛИ отобразит текст «В пределах бюджета». Если лог_выражение равно ИСТИНА, а значение_если_истина пусто, то возвращается значение 0. Чтобы отобразить слово ИСТИНА, необходимо использовать логическое значение ИСТИНА для этого аргумента. Значение_если_истина может быть формулой.

Значение_если_ложь — это значение, которое возвращается, если лог_выражение равно ЛОЖЬ. Например, если этот аргумент — строка «Превышение бюджета» и лог_выражение равно ЛОЖЬ, то функция ЕСЛИ отобразит текст «Превышение бюджета». Если лог_выражение равно ЛОЖЬ, а значение_если_ложь опущено (то есть после значение_если_истина нет точки с запятой), то возвращается логическое значение ЛОЖЬ. Если лог_выражение равно ЛОЖЬ, а значение_если_ложь пусто (то есть после значение_если_истина стоит точка с запятой с последующей закрывающей скобкой), то возвращается значение 0. Значение_если_ложь может быть формулой.

До 7 функций ЕСЛИ могут быть вложены друг в друга в качестве значений аргументов значение_если_истина и значение_если_ложь для конструирования более сложных проверок. См. последний из приведенных ниже примеров.

Когда значения аргументов значение_если_истина и значение_если_ложь вычислены, функция ЕСЛИ возвращает полученное значение.

Если один из аргументов функции ЕСЛИ является массивом, при выполнении функции ЕСЛИ вычисляются все элементы массива.

Microsoft Excel предлагает дополнительные функции, которые можно применять для анализа данных с использованием условий. Например, для вычисления числа появлений текстовой строки или числа в диапазоне ячеек используйте функцию СЧЁТЕСЛИ. Для вычисления суммы значений, попадающих в интервал, заданный текстовой строкой или числами, используйте функцию СУММАЕСЛИ.

Для реализации условий

можно использовать функцию ЕСЛИ, которая последовательно будет проверять выполнение этих условий.

В примере 3 второе предложение ЕСЛИ является в то же время аргументом значение_если_ложь для первого предложения ЕСЛИ. Аналогично, третье предложение ЕСЛИ является аргументом значение_если_ложь для второго предложения ЕСЛИ. Например, если первое лог_выражение (Зн1>89) имеет значение ИСТИНА, то возвращается значение «A». Если первое лог_выражение имеет значение ЛОЖЬ, то вычисляется второе предложение ЕСЛИ и так далее.

Функция ЕСЛИ

В этом курсе:

Функция ЕСЛИ — одна из самых популярных функций в Excel. Она позволяет выполнять логические сравнения значений и ожидаемых результатов.

Поэтому у функции ЕСЛИ возможны два результата. Первый результат возвращается в случае, если сравнение истинно, второй — если сравнение ложно.

Например, функция =ЕСЛИ(C2=»Да»;1;2) означает следующее: ЕСЛИ(С2=»Да», то вернуть 1, в противном случае вернуть 2).

Функция ЕСЛИ, одна из логических функций, служит для возвращения разных значений в зависимости от того, соблюдается ли условие.

ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь])

Условие, которое нужно проверить.

Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

Простые примеры функции ЕСЛИ

    В примере выше ячейка D2 содержит формулу: ЕСЛИ(C2 = Да, то вернуть 1, в противном случае вернуть 2)

      В этом примере ячейка D2 содержит формулу: ЕСЛИ(C2 = 1, то вернуть текст «Да», в противном случае вернуть текст «Нет»). Как видите, функцию ЕСЛИ можно использовать для сравнения и текста, и значений. А еще с ее помощью можно оценивать ошибки. Вы можете не только проверять, равно ли одно значение другому, возвращая один результат, но и использовать математические операторы и выполнять дополнительные вычисления в зависимости от условий. Для выполнения нескольких сравнений можно использовать несколько вложенных функций ЕСЛИ.

      B2;»Превышение бюджета»,»В пределах бюджета»)» xmlns_AntiXSS=»urn:AntiXSSExtensions» />

        =ЕСЛИ(C2>B2;»Превышение бюджета»;»В пределах бюджета»)

        В примере выше функция ЕСЛИ в ячейке D2 означает: ЕСЛИ(C2 больше B2, то вернуть текст «Превышение бюджета», в противном случае вернуть текст «В пределах бюджета»)

        Читать еще:  Как найти сохраненный документ excel

        B2;C2-B2;»»)» xmlns_AntiXSS=»urn:AntiXSSExtensions» />

          На рисунке выше мы возвращаем не текст, а результат математического вычисления. Формула в ячейке E2 означает: ЕСЛИ(значение «Фактические» больше значения «Плановые», то вычесть сумму «Плановые» из суммы «Фактические», в противном случае ничего не возвращать).

            В этом примере формула в ячейке F7 означает: ЕСЛИ(E7 = «Да», то вычислить общую сумму в ячейке F5 и умножить на 8,25 %, в противном случае налога с продажи нет, поэтому вернуть 0)

            Примечание: Если вы используете текст в формулах, заключайте его в кавычки (пример: «Текст»). Единственное исключение — слова ИСТИНА и ЛОЖЬ, которые Excel распознает автоматически.

            Функция ЕСЛИ() в EXCEL

            Функция ЕСЛИ() относится к наиболее часто используемым функциям.

            Синтаксис функции

            ЕСЛИ(лог_выражение;значение_если_истина;[значение_если_ложь])

            Лог_выражение — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. =ЕСЛИ(A1>=100;»Бюджет превышен»;»ОК!») Т.е. если в ячейке A1 содержится значение большее или равное 100, то формула вернет ОК!, а если нет, то Бюджет превышен .

            В качестве аргументов функции, могут участвовать формулы, например: =ЕСЛИ(A1>100;СУММ(B1:B10);СУММ(C1:C10)) Т.е. если в ячейке A1 содержится значение >100, то суммирование ведется по столбцу B , а если меньше, то по столбцу С .

            Вложенные ЕСЛИ

            В EXCEL 2007 в качестве значений аргументов значение_если_истина и значение_если_ложь можно для построения более сложных проверок использовать до 64 вложенных друг в друга функций ЕСЛИ() . =ЕСЛИ(A1>=100;»Бюджет превышен»;ЕСЛИ(A1>=90;»Крупный проект»;ЕСЛИ(A1>=50;»Средний проект»;»Малый проект «)))

            Вышеуказанную формулу можно усложнять и дальше, но есть другие подходы:

            Для функции ВПР() необходимо создать в диапазоне A3:B6 таблицу значений:

            Если требуется вывести разный текст в случае наличия в ячейке А1 отрицательного значения, положительного значения или 0, то можно записать следующую формулу:

            или, если требуется вместо текстовых значений вывести формулы, можно использовать ссылки на диапазон ячеек (содержащих формулы)

            =ПРОСМОТР(A24;<-1E+307;0;1E-307>;A27:A29) (см. файл примера )

            Опущен третий аргумент [значение_если_ложь]

            Третий аргумент функции не обязателен, если его опустить, то функция вернет значение ЛОЖЬ (если условие не выполнено). =ЕСЛИ(A1>100;»Бюджет превышен») Если в ячейке A1 содержится значение 1, то вышеуказанная формула вернет значение ЛОЖЬ.

            Вместо ИСТИНА или ЛОЖЬ в первом аргументе введено число

            Т.к. значение ЛОЖЬ эквивалентно 0, то формулы =ЕСЛИ(0;»Бюджет превышен»;»ОК!») или (если в ячейке A1 содержится значение 0) =ЕСЛИ(A1;»Бюджет превышен»;»ОК!») вернут ОК!

            Если в ячейке A1 находится любое другое число кроме 0, то формула вернет Бюджет превышен . Такой подход удобен, когда проверяется равенство значения нулю.

            Связь функции ЕСЛИ() с другими функциями использующие условия

            EXCEL содержит также другие функции, которые можно применять для анализа данных с использованием условий. Например, для подсчета количества вхождений чисел в диапазоне ячеек используется функция СЧЁТЕСЛИ() , а для сложения значений, удовлетворяющих определенным условиям, используется функция СУММЕСЛИ() .

            Функция ЕСЛИ() , как альтернативный вариант, может быть также использована для подсчета и сложения значений с использованием условий. Ниже приведены иллюстрирующие примеры.

            Пусть данные находятся в диапазоне A6:A11 (см. файл примера)

            Подсчитаем сумму значений, которые больше 10 с помощью функции СУММЕСЛИ() , записав =СУММЕСЛИ(A6:A11;»>10″) . Аналогичный результат (23) можно получить с помощью формулы массива =СУММ(ЕСЛИ(A6:A11>10;A6:A11)) (для ввода формулы в ячейку вместо ENTER нужно нажать CTRL+SHIFT+ENTER )

            Теперь подсчитаем количество вхождений чисел больше 10 в диапазоне ячеек A6:A11 =СЧЁТЕСЛИ(A6:A11;»>10″) . Аналогичный результат (2) можно получить с помощью формулы массива =СЧЁТ(ЕСЛИ(A6:A11>10;A6:A11))

            Теперь, когда принцип понятен, с помощью функции ЕСЛИ() можно конструировать и другие формулы с условиями. Например, нахождение минимального значения среди чисел больше 10: =МИН(ЕСЛИ(A6:A11>10;A6:A11))

            Excel: Функция ЕСЛИ

            Функция Если является одной из самых полезных функций в Excel. Она позволяет получать разные значения ячейки в зависимости от выполнения какого-либо условия, а также находить ошибки, уникальные значения в списке, использовать многократные проверки на выполнение условий и многое другое.

            Функция Если проверяет значение логического выражения и возвращает результаты в зависимости от того, истинно оно или ложно.

            Аргументы функции Если

            Если (лог_выражение; [значение_если_истина]; [значение_если_ложь])

            1. Лог_выражение — логическое выражение

            Логические выражения используются для записи условий, в которых сравниваются числа, функции, формулы, текстовые значения. Логическое выражение может принимать одно из двух значений — Истина или Ложь.

            Читать еще:  Виды фильтрации в excel

            Например, «A10=100» — логическое выражение; если значение в ячейке A10 равно 100, это выражение принимает значение Истина, в противном случае — значение Ложь.
            В этом аргументе может использоваться любой оператор сравнения .

            • > больше
            • = больше или равно
            • не равно
            1. Значение_если_истина — значение, которое помещается в ячейку (возвращается), если лог_выражение соответствует значению Истина.

            Значение может быть числом, текстом, формулой или ссылкой на ячейку.

            1. Значение_если_ложь — значение, которое возвращается, если лог_выражение соответствует значению Ложь.

            Значение может быть числом, текстом, формулой или ссылкой на ячейку.

            Обязателен только первый аргумент (логическое выражение). Если опустить второй и третий аргумент, то вместо заданных нами значений будут выводиться значения «Истина» или «Ложь» в зависимости от истинности логического выражения.

            Примеры:

            Если значение в ячейке А1 больше 5, формула возвращает значение 10, в противном случае — 20:

            2. Если (А1>=3 ; «Зачет сдал» ; «Зачет не сдал»)

            Если в ячейке А1 оценка больше или равна 3, то зачет сдан, в противном случае – нет.

            3. =Если (А1=«оплачено»; В1; 0)

            Эта формула возвращает значение из ячейки В1, если ячейка А1 содержит слово «оплачено», и 0, если в ней находится любое другое значение. Совпадение между сравниваемыми текстовыми значениями должно быть точным, но без учета регистра.

            Для создания более сложных проверок в качестве аргументов можно использовать функции Если , вложенные друг в друга.
            В Excel версий до 2003 включительно — до 7 вложений;
            вExcel версии 2007 — до 64 вложений;
            в Excel версии 2010 — до 128 вложений.

            Понравилось? Поделись с друзьями

            Семинары. Вебинары. Конференции

            Актуальные темы. Лучшие лекторы Москвы и РФ. Сертификаты ИПБР. Более 30 тематик в месяц.

            Использование логических функций в Excel

            Табличный редактор Эксель – очень гибкий и мощный инструмент для структурированной работы с данными. Среди большого количества его эффективных инструментов стоит отдельно выделить логические операторы, в основе использования которых лежит признание выражения истинным или ложным. Эти функции эффективно встроены в инструментарий формул и позволяют создавать гибкие условия для различных вычислений или заполнения ячеек на основе логических выражений. В данной статье будут описаны основные используемые функции, а также приведен практический пример использования логических операторов в Excel.

            Основные логические функции, используемые в Эксель

            Перечень наиболее часто используемых логических операторов можно ограничить следующим набором:

            В большинстве случаев их достаточно для построения сложных логических конструкций и задания условий.

            Для каждого из указанных выше операторов существуют аргументы (за исключением функций ИСТИНА и ЛОЖЬ) – это могут быть как цифровые или текстовые значения, так и ссылки на данные, содержащиеся в других ячейках.

            Операторы ИСТИНА и ЛОЖЬ

            Функция ИСТИНА не имеет собственных аргументов и практически всегда используется, как структурный компонент для других логических выражений, так как принимает одно конкретно заданное значение.

            Функция ЛОЖЬ, напротив, может принимать любые значения, не являющиеся истинными. Как и ИСТИНА, практически всегда используется, как структурный компонент для других сложных выражений.

            Операторы И и ИЛИ

            Синтаксис оператора И выглядит следующим образом:

            =И(лог_значение1; лог_значение2; …), возможное количество используемых аргументов – от 1 до 255.

            Оператор И используется в качестве элемента-связки для нескольких условий логического выражения. Важно, чтобы все аргументы оператора имели значение ИСТИНА (если в выражении их несколько), в противном случае вся логическая цепочка будет возвращать значение ЛОЖЬ.

            Синтаксис оператора ИЛИ:

            =ИЛИ(лог_значение1; лог_значение2; …), возможное количество используемых аргументов – от 1 до 255.

            В отличие от И, функция ИЛИ будет возвращать значение ИСТИНА даже в случае, когда хотя бы один из используемых аргументов ему соответствует, а все остальные – ложные.

            Оператор НЕ

            Синтаксис функции НЕ: =НЕ(лог_значение).

            Количество аргументов оператора НЕ – всегда один. Соответственно, результат функции (ИСТИНА/ЛОЖЬ) полностью зависит только от значения аргумента.

            Операторы ЕСЛИ и ЕСЛИОШИБКА

            Общий синтаксис функции ЕСЛИ представляет собой конструкцию:

            =ЕСЛИ(логическое_выражение;значение_если_истина;значение_если-ложь).

            Оператор ЕСЛИ используется для построения сложных развернутых логических цепочек. Суть функции – в проверке внесенного в качестве логического выражения условия. Если условие выполняется, и оно истинно, то в качестве результата функции возвращается одно выражение, если же логическое выражение ложно, то в качестве результата функции возвращается другое условие.

            Читать еще:  Как снять защиту с документа excel

            Синтаксис оператора ЕСЛИОШИБКА имеет вид:

            =ЕСЛИОШИБКА(значение;значение_если_ошибка).

            Функция проверяет истинность логического выражения для первого аргумента, и если он соблюдается, то возвращает в качестве результата его значение. Если же выражение ложно, то в качестве результата выдается значение второго аргумента, указанное в функции.

            Операторы ЕОШИБКА и ЕПУСТО

            Оператор ЕОШИБКА имеет следующую структуру:

            =ЕОШИБКА(значение)

            Он позволяет осуществить проверку корректности уже заполненных ячеек (одной или диапазона), и, если ячейка некорректно заполнена, возвращает результат ИСТИНА, в противном случае – ЛОЖЬ.

            Примеры значений в некорректно заполненных ячейках:

            Аргумент функции – адрес конкретной ячейки или ссылка на диапазон ячеек.

            Формула функции ЕПУСТО выглядит следующим образом:

            =ЕПУСТО(значение)

            Функционал оператора проверяет ячейку или диапазон ячеек и возвращает ИСТИНА, если в ячейке/диапазоне ячеек нет данных, и ЛОЖЬ, если в ячейке/диапазоне ячеек присутствуют данные. Аргумент функции – адрес конкретной ячейки или ссылка на диапазон ячеек.

            Практический пример использования логических функций

            В примере ниже попробуем частично использовать описанные выше функции для решения задачи, приближенной к реальной ситуации с расчетом премии, зависящей от определенных условий.

            В качестве исходных данных – таблица со сведениями о работниках, в которой указан их пол и возраст.

            Нам необходимо произвести расчет премии. Ключевые условия, от которых зависит размер премии:

            • величина обычной премии, которую получат все сотрудники без исключения – 3 000 руб.;
            • сотрудницам женского пола положена повышенная премия – 7 000 руб.;
            • молодым сотрудникам (младше 1984 г. рождения) положена повышенная премия – 7 000 руб.;

            Выполним необходимые расчеты, используя логические функции.

            1. Встаем в первую ячейку столбца, в которой хотим посчитать размеры премий и щелкаем кнопку “Вставить функцию” (слева от сроки формул).
            2. В открывшемся Мастере функций выбираем категорию “Логические”, затем в предложенном перечне операторов кликаем по строке “ЕСЛИ” и жмем OK.
            3. Теперь нам нужно задать аргументы функции. Так как у нас не одно, а два условия получения повышенной премии, причем нужно, чтобы выполнялось хотя бы одно из них, чтобы задать логическое выражение, воспользуемся функцией ИЛИ. Находясь в поле для ввода значения аргумента “Лог_выражение” кликаем в основной рабочей области книги на небольшую стрелку вниз, расположенную в левой верхней части окна программы, где обычно отображается адрес ячейки. В открывшемся списке функций выбираем оператор ИЛИ, если он представлен в перечне (или можно кликнуть на пункт “Другие функции” и выбрать его в новом окне Мастера функций, как мы изначально сделали для выбора оператора ЕСЛИ).
            4. Мы переключимся в окно аргументов функци ИЛИ. Здесь задаем наши условия получения премии в 7000 руб.:
              • год рождения позже 1984 года;
              • пол – женский;
            5. Теперь обращаем внимание на строку формул. Кликаем в ней на название первоначального оператора ЕСЛИ, чтобы переключиться в аргументы этой функции.
            6. Заполняем аргументы функции и щелкаем OK:
              • в значении “Истина” пишем цифру 7000;
              • в значении “Ложь” указываем цифру 3000;
            7. Результат работы логических операторов отобразится в первой ячейке столбца, которую мы выбрали. Как мы можем видеть, окончательный вид формулы выглядит следующим образом:
              =ЕСЛИ(ИЛИ(C2>1984;D2=»жен.»);7000;3000) .
              Кстати, вместо использования Мастера функций можно было вручную составить и прописать данную формулу в требуемой ячейке.
            8. Чтобы рассчитать премию для всех сотрудников, воспользуемся Маркером заполнения. Наведем курсор на правый нижний угол ячейки с формулой. После того, как курсор примет форму черного крестика (это и есть Маркер заполнения), зажимаем левую кнопку мыши и протягиваем выделение вниз, до последней ячейки столбца.
            9. Все готово. Благодаря логическим операторам мы получили заполненные данные для столбца с премиями.

            Заключение

            Логические операторы используются практически во всех сложных формулах, в которых значение в ячейке зависит от соблюдения одного или нескольких условий и позволяют строить гибкие конструкции, объединяя простые функции и расчеты в одной ячейке. Это дает возможность значительно сократить время на обработку данных и повысить эффективность работы, так как снимает большое количество промежуточных шагов в расчетах и вычислениях.

            Ссылка на основную публикацию
            Adblock
            detector