Green-sell.info

Новые технологии
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Как делать условия в excel

Как в excel поставить условие

Как задать простое логическое условие в Excel

​Смотрите также​ умножать частное на​ Константы формулы –​ есть вводить в​или​ Для удобства также​ введите функцию в​ можно ввести вопрос,​ формулах в Exce​ точные значения в​Совет:​​ учетом 12 условий!​​ ЕСЛИ и обеспечить​​ успехов в изучении​​Плохо​ функции Excel для​ ячеек A1 и​В Excel существует множество​

  • ​ 100. Выделяем ячейку​
  • ​ ссылки на ячейки​ формулу числа и​
  • ​если результат находится​

Операторы сравнения в Excel

​ приводим ссылку на​ поле аргумента в​ описывающий необходимые действия,​lРекомендации, позволяющие избежать​ таблице подстановки, а​ Чтобы сложные формулы было​ Вот так будет​

Как задать условие в Excel

​ их правильную отработку​ Microsoft Excel!​в остальных случаях.​ задания сложных условий.​ B1 не равны.​ различных функций, работа​

​ с результатом и​​ с соответствующими значениями.​ операторы математических вычислений​ в диапазоне, то​ оригинал (на английском​ построитель формул или​ в поле​ появления неработающих формул​ также все значения,​ проще читать, вы​ выглядеть ваша формула:​ по каждому условию​Автор: Антон Андронов​Чтобы решить эту задачу,​

​Обратимся к примеру, приведенному​​ В противном случае​ которых построена на​ нажимаем «Процентный формат».​Нажимаем ВВОД – программа​ и сразу получать​ выделить цветом, то​ языке) .​ непосредственно в ячейку.​Поиск функции​Поиск ошибок в​

​ попадающие между ними.​ можете вставить разрывы​=ЕСЛИ(B2>97;»A+»;ЕСЛИ(B2>93;»A»;ЕСЛИ(B2>89;»A-«;ЕСЛИ(B2>87;»B+»;ЕСЛИ(B2>83;»B»;ЕСЛИ(B2>79;»B-«; ЕСЛИ(B2>77;»C+»;ЕСЛИ(B2>73;»C»;ЕСЛИ(B2>69;»C-«;ЕСЛИ(B2>57;»D+»;ЕСЛИ(B2>53;»D»;ЕСЛИ(B2>49;»D-«;»F»))))))))))))​ на протяжении всей​Функция ЕСЛИ позволяет выполнять​ введем в ячейку​ на рисунках ниже.​ – ЛОЖЬ.​ проверке логических условий.​ Или нажимаем комбинацию​

​ отображает значение умножения.​ результат.​ для этого нужно​Один быстрый и простой​Введите дополнительные аргументы, необходимые​(например, при вводе​ формулах​

​ В этом случае​​ строк в строке​Она по-прежнему точна и​ цепочки. Если при​ логические сравнения значений​ C3 следующую формулу:​ В данном примере​

​В Excel существуют логические​ Например, это функции​​ горячих клавиш: CTRL+SHIFT+5​​ Те же манипуляции​​Но чаще вводятся адреса​​ использовать Формат->Условное форматирование​ для добавления значений​ для завершения формулы.​ «добавить числа» возвращается​Логические функции​ таблицы подстановки нужно​ формул. Просто нажмите​ будет правильно работать,​ вложении вы допустите​ и ожидаемых результатов.​=ЕСЛИ(B3>60;»Отлично»;ЕСЛИ(B2>45;»Хорошо»;»Плохо»))​ функция​ функции​

​ ЕСЛИ, СЧЕТЕСЛИ, СУММЕСЛИ​Копируем формулу на весь​ необходимо произвести для​ ячеек. То есть​Nosirbey​ в Excel всего​Завершив ввод аргументов формулы,​ функция​Функции Excel (по​ сортировать по возрастанию,​​ клавиши ALT+ВВОД перед​​ но вы потратите​​ в формуле малейшую​​ Она проверяет условие​

Функция ЕСЛИ в Excel на простом примере

​ЕСЛИ​​ИСТИНА()​​ и т.д. Также​ столбец: меняется только​ всех ячеек. Как​ пользователь вводит ссылку​: Для этого используются​ воспользоваться функцией Автосумма.​ нажмите клавишу ВВОД.​СУММ​ алфавиту)​ от меньшего к​ текстом, который хотите​ много времени, чтобы​ неточность, она может​ и в зависимости​Enter​​в первую очередь​​и​

Коротко о синтаксисе

​ логические условия можно​​ первое значение в​​ в Excel задать​ на ячейку, со​

​ Логические функции​

​ Выделите пустую ячейку​Ниже приведен пример использования​).​Функции Excel (по​ большему.​ перенести на другую​ написать ее, а​ сработать в 75 %​ от его истинности​.​ проверят условие​ЛОЖЬ()​ задавать в обычных​

​ формуле (относительная ссылка).​ формулу для столбца:​ значением которой будет​Silenser​ непосредственно под столбцом​ вложенных функций ЕСЛИ​Чтобы ввести другую функцию​ категориям)​

Пример 1

​Функция ВПР подробно рассматривается​ строку.​ потом протестировать. Еще​ случаев, но вернуть​​ возвращает результат.​​Данная формула обрабатывает сразу​A1>25​​, которые не имеют​​ формулах, если необходимо​ Второе (абсолютная ссылка)​ копируем формулу из​ оперировать формула.​: Есть функции ЕСЛИ,​ данных. На вкладке​ для назначения буквенных​

Пример 2

​ в качестве аргумента,​​Примечание:​​ здесь, но очевидно,​Перед вами пример сценария​ одна очевидная проблема​ непредвиденные результаты в​=ЕСЛИ(это истинно, то сделать​ два условия. Сначала​. Если это так,​ аргументов. Данные функции​

​ получить утвердительный ответ:​ остается прежним. Проверим​ первой ячейки в​При изменении значений в​ ИЛИ, И, а​​ «​​ категорий числовым результатам​​ введите функцию в​​Мы стараемся как​ что она значительно​ для расчета комиссионных​ состоит в том,​

  1. ​ остальных 25 %. К​ это, в противном​ проверяется первое условие:​ то формула возвратит​
  2. ​ существуют в основном​​Да​​ правильность вычислений –​​ другие строки. Относительные​​ ячейках формула автоматически​
  3. ​ можно просто использовать​формулы​ тестирования.​ поле этого аргумента.​ можно оперативнее обеспечивать​ проще, чем сложный​ с неправильной логикой:​
  4. ​ что вам придется​ сожалению, шансов отыскать​ случае сделать что-то​B3>60​ текстовую строку «больше​

Функция ЕСЛИ и несколько условий

​ для обеспечения совместимости​​или​​ найдем итог. 100%.​ ссылки – в​ пересчитывает результат.​ знаки <>​» нажмите кнопку​Скопируйте образец данных из​Части формулы, отображенные в​ вас актуальными справочными​ 12-уровневый вложенный оператор​Видите, что происходит? Посмотрите​ вручную вводить баллы​​ эти 25 % немного.​​ еще)​. Если оно истинно,​ 25», в любом​​ с другими электронными​​Нет​ Все правильно.​​ помощь.​​Ссылки можно комбинировать в​

    ​Формула предписывает программе Excel​Автосумма​ следующей таблицы и​​ диалоговом окне​​ материалами на вашем​​ ЕСЛИ. Есть и​​ порядок сравнения доходов​

  • ​ и эквивалентные буквенные​Работа с множественными операторами​Поэтому у функции ЕСЛИ​​ то формула возвращает​​ другом случае —​ таблицами. Вы можете​. К примеру, задавая​При создании формул используются​Находим в правом нижнем​ рамках одной формулы​ порядок действий с​​>​​ вставьте их в​​Аргументы функции​​ языке. Эта страница​ другие, менее очевидные,​ в предыдущем примере.​ оценки. Каковы шансы,​ ЕСЛИ может оказаться​
  • ​ возможны два результата.​ значение «Отлично», а​ «меньше или равно​ вводить значения ИСТИНА​ простые логические условия,​ следующие форматы абсолютных​ углу первой ячейки​ с простыми числами.​
  • ​ числами, значениями в​Сумма​ ячейку A1 нового​​, отображают функцию, выбранную​​ переведена автоматически, поэтому​ преимущества:​​ А как все​​ что вы не​ чрезвычайно трудоемкой, особенно​ Первый результат возвращается​ остальные условия не​ 25».​ и ЛОЖЬ прямо​ Вы можете ответить​ ссылок:​ столбца маркер автозаполнения.​Оператор умножил значение ячейки​ ячейке или группе​. Excel автоматически будут​ листа Excel. Чтобы​

    ​ на предыдущем шаге.​ ее текст может​Таблицы ссылок функции ВПР​ идет в этом?​​ ошибетесь? А теперь​​ если вы вернетесь​​ в случае, если​​ обрабатываются. Если первое​

    Читать еще:  Excel 2020 отдельные окна

    ​Функция​ в ячейки или​ на такие вопросы:​​$В$2 – при копировании​​ Нажимаем на эту​ В2 на 0,5.​ ячеек. Без формул​ определения диапазона, который​ отобразить результаты формул,​Если щелкнуть элемент​​ содержать неточности и​​ открыты и их​ Именно! Сравнение идет​ представьте, как вы​ к ним через​ сравнение истинно, второй —​ условие ложно, то​ЕСЛИ​

    ​ формулы, не используя​

    Функция ЕСЛИ — вложенные формулы и типовые ошибки

    ​5 больше 8?​ остаются постоянными столбец​ точку левой кнопкой​ Чтобы ввести в​ электронные таблицы не​ необходимо суммировать. (Автосумма​ выделите их и​

    ​ЕСЛИ​ грамматические ошибки. Для​ легко увидеть.​ снизу вверх (от​

    ​ пытаетесь сделать это​ какое-то время и​ если сравнение ложно.​ функция​является очень гибкой​ форму записи функции,​

    ​Содержимое ячейки A5 меньше​ и строка;​ мыши, держим ее​ формулу ссылку на​ нужны в принципе.​ также можно работать​ нажмите клавишу F2,​, в диалоговом окне​ нас важно, чтобы​Значения в таблицах просто​ 5 000 до 15 000 ₽),​ 64 раза для​ попробуете разобраться, что​Операторы ЕСЛИ чрезвычайно надежны​ЕСЛИ​ и ее можно​ Excel все прекрасно​

    ​ 8?​B$2 – при копировании​ и «тащим» вниз​

    Технические подробности

    ​ ячейку, достаточно щелкнуть​Конструкция формулы включает в​ по горизонтали при​ а затем — клавишу​Аргументы функции​ эта статья была​

    Канал в Telegram

    Вы здесь

    Функции Excel.Функция И(), ИЛИ()

    На прошлом уроке «Функции Excel. Функция ЕСЛИ» была рассмотрена работа со встроенной функцией ЕСЛИ(). Все бы хорошо, но возникают такие ситуации, и довольно часто, когда вложенностью условия в условие не обойтись. Например, элементарно необходимо проверить следующее: 1 больше или равно x и x меньше или равно 5 . Реализовать такое условие несколькими ЕСЛИ довольно громоздко и проблематично, а в некоторых ситуациях — вообще невозможно. Для расширения функционала ЕСЛИ и облегчения составления формул с условием, в Excel имеются еще пара полезных функции — И() и ИЛИ().

    Функция И()

    Функция И() используется тогда, когда необходимо проверить несколько условий следующим образом — Условие 1 И Условие 2. При этом все условия должны быть истинными. Результатом работы данной функции является ИСТИНА или ЛОЖЬ (TRUE / FALSE). Пример: ЕСЛИ а = b И а=с ТОГДА значение 1 ИНАЧЕ значение 2.
    Как видно из примера, значение 1 будет только в том случае, если все условия верны.

    Функция ИЛИ()

    Функция ИЛИ() используется тогда, когда необходимо проверить несколько условий следующим образом — Условие 1 ИЛИ Условие 2. Результат функции будет истинным, если хотя бы одно из условий истинно. Пример: ЕСЛИ а = b ИЛИ а=с ТОГДА значение 1 ИНАЧЕ значение 2.

    Синтаксис функций И() и ИЛИ() одинаков: Функция(Условие 1; Условие 2; Условие 3 и до 30-ти условий). Результат ИСТИНА или ЛОЖЬ.

    Примеры использования функции И и ИЛИ

    Все вышесказанное сложно к пониманию и относится к разделу Мат. логики и Дискретной математики. Попробую это все изложить на понятном языке. Разберем несколько примеров. Скажу сразу, все примеры будут с использованием функции ЕСЛИ.

    Пример 1.
    Столбец А, начиная с первой строки, содержит 56, 55, 88, 6, 74. Столбец В — 52, 55, 88, 4, 25. Столбец С — 53, 55, 88, 6, 25. С помощью функций ЕСЛИ и И необходимо определить строки, значения которых равны следующим образом А=В и В=С.

    Переходим в ячейку D1 и с помощью мастера функций вводим следующее

    Формула будет выглядеть так: “ =ЕСЛИ(И(A1=B1;B1=C1);»Все значения равны»;»Значения не равны») “

    Пример 2.

    Теперь пример на функцию ИЛИ. Те же столбцы, те же значения, условие следующее: с помощью функций ЕСЛИ и ИЛИ необходимо определить строки, в которых есть совпадающие значения А=В или В=С или А=С.

    Мастер функций выглядит так:

    Формула: “ =ЕСЛИ(ИЛИ(A1=B1;B1=C1;A1=C1);»Есть равные значения»;»Нет равных значений»)”

    Вот и все. Функции не сложны. Применяйте их там, где встречаются условия и произносится И и ИЛИ. Так же, всеми выше перечисленными функциями можно сравнивать текстовые значения.

    И напоследок рассмотрим еще один пример с функцией И и ИЛИ из реальной жизни.

    Пример 3.

    В таблицу занесены процент выполнения заданий, необходимо проценты перевести в пятибалльную систему следующим образом:

    Таблица следующего вида:

    Составим формулу следующего вида:

    =ЕСЛИ(ИЛИ(И(B1>0;B1 0,11;B1 0,31;B1 0,41;B1 0,76;B1

    Функция IF (ЕСЛИ) в Excel. Как использовать?

    Функция IF (ЕСЛИ) в Excel – это отличный инструмент для проверки условий на ИСТИНУ или ЛОЖЬ. Если значения ваших расчетов равны заданным параметрам функции как ИСТИНА, то она возвращает одно значение, если ЛОЖЬ, то другое.

    Что возвращает функция

    Заданное вами значение при выполнении двух условий ИСТИНА или ЛОЖЬ.

    Синтаксис

    =IF(logical_test, [value_if_true], [value_if_false]) – английская версия

    =ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь]) – русская версия

    Аргументы функции

    • logical_test (лог_выражение) – это условие, которое вы хотите протестировать. Этот аргумент функции должен быть логичным и определяемым как ЛОЖЬ или ИСТИНА. Аргументом может быть как статичное значение, так и результат функции, вычисления;
    • [value_if_true] ([значение_если_истина]) – (не обязательно) – это то значение, которое возвращает функция. Оно будет отображено в случае, если значение которое вы тестируете соответствует условию ИСТИНА;
    • [value_if_false] ([значение_если_ложь]) – (не обязательно) – это то значение, которое возвращает функция. Оно будет отображено в случае, если условие, которое вы тестируете соответствует условию ЛОЖЬ.

    Дополнительная информация

    • В функции IF (ЕСЛИ) может быть протестировано 64 условий за один раз;
    • Если какой-либо из аргументов функции является массивом – оценивается каждый элемент массива;
    • Если вы не укажете условие аргумента FALSE (ЛОЖЬ) value_if_false (значение_если_ложь) в функции, т.е. после аргумента value_if_true (значение_если_истина) есть только запятая (точка с запятой), функция вернет значение “0”, если результат вычисления функции будет равен FALSE (ЛОЖЬ).
      На примере ниже, формула =IF(A1> 20,”Разрешить”) или =ЕСЛИ(A1>20;”Разрешить”) , где value_if_false (значение_если_ложь) не указано, однако аргумент value_if_true (значение_если_истина) по-прежнему следует через запятую. Функция вернет “0” всякий раз, когда проверяемое условие не будет соответствовать условиям TRUE (ИСТИНА).

    |

  • Если вы не укажете условие аргумента TRUE(ИСТИНА) (value_if_true (значение_если_истина)) в функции, т.е. условие указано только для аргумента value_if_false (значение_если_ложь), то формула вернет значение “0”, если результат вычисления функции будет равен TRUE (ИСТИНА);
    На примере ниже формула равна = IF (A1>20;«Отказать») или =ЕСЛИ(A1>20;”Отказать”) , где аргумент value_if_true (значение_если_истина) не указан, формула будет возвращать “0” всякий раз, когда условие соответствует TRUE (ИСТИНА).
  • Читать еще:  Сортировка в excel по возрастанию цифр

    Функция Если в Excel примеры с несколькими условиями

    Пример 1. Проверяем простое числовое условие с помощью функции IF (ЕСЛИ)

    При использовании функции IF (ЕСЛИ) в Excel, вы можете использовать различные операторы для проверки состояния. Вот список операторов, которые вы можете использовать:

    Ниже приведен простой пример использования функции при расчете оценок студентов. Если сумма баллов больше или равна “35”, то формула возвращает “Сдал”, иначе возвращается “Не сдал”.

    Пример 2. Использование вложенной функции IF (ЕСЛИ) для проверки условия выражения

    Функция может принимать до 64 условий одновременно. Несмотря на то, что создавать длинные вложенные функции нецелесообразно, то в редких случаях вы можете создать формулу, которая множество условий последовательно.

    В приведенном ниже примере мы проверяем два условия.

    • Первое условие проверяет, сумму баллов не меньше ли она чем 35 баллов. Если это ИСТИНА, то функция вернет “Не сдал”;
    • В случае, если первое условие – ЛОЖЬ, и сумма баллов больше 35, то функция проверяет второе условие. В случае если сумма баллов больше или равна 75. Если это правда, то функция возвращает значение “Отлично”, в других случаях функция возвращает “Сдал”.

    Пример 3. Вычисляем сумму комиссии с продаж с помощью функции IF (ЕСЛИ) в Excel

    Функция позволяет выполнять вычисления с числами. Хороший пример использования – расчет комиссии продаж для торгового представителя.

    В приведенном ниже примере, торговый представитель по продажам:

    • не получает комиссионных, если объем продаж меньше 50 тыс;
    • получает комиссию в размере 2%, если продажи между 50-100 тыс
    • получает 4% комиссионных, если объем продаж превышает 100 тыс.

    Рассчитать размер комиссионных для торгового агента можно по следующей формуле:

    В формуле, использованной в примере выше, вычисление суммы комиссионных выполняется в самой функции ЕСЛИ . Если объем продаж находится между 50-100K, то формула возвращает B2 * 2%, что составляет 2% комиссии в зависимости от объема продажи.

    Пример 4. Используем логические операторы (AND/OR) (И/ИЛИ) в функции IF (ЕСЛИ) в Excel

    Вы можете использовать логические операторы (AND/OR) (И/ИЛИ) внутри функции для одновременного тестирования нескольких условий.

    Например, предположим, что вы должны выбрать студентов для стипендий, основываясь на оценках и посещаемости. В приведенном ниже примере учащийся имеет право на участие только в том случае, если он набрал более 80 баллов и имеет посещаемость более 80%.

    Вы можете использовать функцию AND (И) вместе с функцией IF (ЕСЛИ) , чтобы сначала проверить, выполняются ли оба эти условия или нет. Если условия соблюдены, функция возвращает “Имеет право”, в противном случае она возвращает “Не имеет право”.

    Формула для этого расчета:

    =IF(AND(B2>80,C2>80%),”Да”,”Нет”) – английская версия

    =ЕСЛИ(И(B2>80;C2>80%);”Да”;”Нет”) – русская версия

    Пример 5. Преобразуем ошибки в значения “0” с помощью функции IF (ЕСЛИ)

    С помощью этой функции вы также можете убирать ячейки содержащие ошибки. Вы можете преобразовать значения ошибок в пробелы или нули или любое другое значение.

    Формула для преобразования ошибок в ячейках следующая:

    =IF(ISERROR(A1),0,A1) – английская версия

    =ЕСЛИ(ЕОШИБКА(A1);0;A1) – русская версия

    Формула возвращает “0”, в случае если в ячейке есть ошибка, иначе она возвращает значение ячейки.

    ПРИМЕЧАНИЕ. Если вы используете Excel 2007 или версии после него, вы также можете использовать функцию IFERROR для этого.

    Точно так же вы можете обрабатывать пустые ячейки. В случае пустых ячеек используйте функцию ISBLANK, на примере ниже:

    =IF(ISBLANK(A1),0,A1) – английская версия

    =ЕСЛИ(ЕПУСТО(A1);0;A1) – русская версия

    Функция ЕСЛИ в Excel на простом примере

    Функция ЕСЛИ одна из самых популярных и часто используемых функций Excel. Используя ее совместно с операторами сравнения и другими логическими функциями Excel, можно решать достаточно сложные задачи. В этом уроке мы попробуем разобрать ее действие на простых примерах, а также научимся использовать сразу несколько функций ЕСЛИ в одной формуле.

    Коротко о синтаксисе

    Функция ЕСЛИ имеет всего три аргумента:

    =ЕСЛИ(заданное_условие; значение_если_ИСТИНА; значение_если_ЛОЖЬ)

    Первый аргумент – это условие, благодаря которому формула может принимать решения. Условие проверяется в самую первую очередь и способно вернуть всего два значения – ИСТИНА или ЛОЖЬ. Если условие истинно, то формула вернет второй аргумент, в противном случае третий.

    Пример 1

    Обратимся к примеру, приведенному на рисунках ниже. В данном примере функция ЕСЛИ в первую очередь проверят условие A1>25. Если это так, то формула возвратит текстовую строку “больше 25”, в любом другом случае – “меньше или равно 25”.

    Пример 2

    Функция ЕСЛИ является очень гибкой и ее можно применять в различных ситуациях. Рассмотрим еще один пример. В таблице ниже приведены результаты переаттестации сотрудников фирмы:

    В столбец C нам необходимо выставить результат экзамена, который должен содержать всего два варианта: Сдал или Не сдал. Те, кто набрал более 45 баллов – сдали экзамен, остальные нет.

    1. Выделите ячейку, в которую необходимо ввести формулу. В нашем случае это ячейка C3.
    2. Введите в нее выражение: =ЕСЛИ(B3>45; “Сдал”; “Не сдал”) и нажмите Enter.
    3. Данная формула сравнивает значение в ячейке B3 с числом 45, если значение больше 45, то возвращает строку “Сдал”, иначе “Не сдал”.
    4. Скопировав формулу в остальные ячейки таблицы, можно увидеть, что 2 человека из 5 не прошли переаттестацию.

    Функция ЕСЛИ и несколько условий

    Функции ЕСЛИ можно вкладывать друг в друга, если необходимо расширить варианты принятия решений в Excel. Например, для рассмотренного ранее случая переаттестации сотрудников, требуется проставить не результат, а оценку из ряда: Отлично, Хорошо и Плохо. Оценка Отлично ставится при количестве баллов более 60, оценка Хорошо при более 45 и оценка Плохо в остальных случаях.

      Чтобы решить эту задачу, введем в ячейку C3 следующую формулу:=ЕСЛИ(B3>60;”Отлично”;ЕСЛИ(B2>45;”Хорошо”;”Плохо”)) и нажмем Enter.

    Читать еще:  Автоматическая ширина строк в excel

  • Данная формула обрабатывает сразу два условия. Сначала проверяется первое условие: B3>60. Если оно истинно, то формула возвращает значение “Отлично”, а остальные условия не обрабатываются. Если первое условие ложно, то функция ЕСЛИ переходит ко второму: B2>45. Если второе условие истинно, то формула возвращает значение “Хорошо”, а если ложно, то “Плохо”.
  • Скопировав формулу в остальные ячейки таблицы, можно увидеть, что на отлично сдал один человек, а на оценки хорошо и плохо по два человека.
  • Как видите, вместо второго и третьего аргументов функции ЕСЛИ можно подставлять новые функции ЕСЛИ, тем самым расширяя число условий, которое формула может обработать. Таким образом, Вы можете создать нужное количество вложений. Правда есть очевидный недостаток такой конструкции, после 3-5 вложений формула станет нечитаемой и громоздкой, и с ней будет невозможно работать.

    В Excel существуют более благородные инструменты для обработки большого количества условий, например, функция ВПР или ПРОСМОТР.

    Итак, в этом уроке мы рассмотрели логическую функцию ЕСЛИ во всей ее красе и примерах, а также разобрали простой пример с использованием сразу нескольких функций ЕСЛИ в одной формуле. Надеюсь, что эта информация была для Вас полезной. Удачи Вам и больших успехов в изучении Microsoft Excel!

    ITGuides.ru

    Вопросы и ответы в сфере it технологий и настройке ПК

    Примеры использования функции проверки условия (ЕСЛИ) в Excel

    Функция ЕСЛИ относится к логическим функциям Microsoft Excel и является одной из наиболее часто используемых в работе. С помощью этого оператора можно выполнять различные задачи, когда необходимо сравнить какие-то данные и выдать результат. Функция ЕСЛИ в Excel дает возможность использовать в работе ветвящиеся алгоритмы, строить дерево решений и т.д.

    Видео по использованию функции ЕСЛИ в Excel

    Примеры использования оператора ЕСЛИ

    Функция ЕСЛИ выглядит следующим образом:

    =ЕСЛИ (выражение; истина; ложь).

    А теперь немного подробнее:

    1. Выражение — это логическое выражение, которое может быть числом или фразой. Например «10» — это логическое выражение, «без НДС» — тоже логическое выражение. Это единственный параметр, который заполняется в обязательном порядке.
    2. Истина — значение, которое будет выдано в качестве результата, если выражение окажется истинным.
    3. Ложь — значение, которое будет выдано, если выражение будет ложным.

    Простейший пример реализации функции ЕСЛИ в Excel — проверяем равенство значений двух ячеек

    К примеру, можно ввести в поле C1 цифру 8, а в поле D1 написать так: =ЕСЛИ(C1 );

  • меньше ( =);
  • меньше или равно ( ).
  • Примеры функций И, ИЛИ

    Также при использовании в Экселе функции ЕСЛИ есть возможность соединить ее с простыми операторами сравнения (вроде И, ИЛИ). Например, можно написать такое условие: =ЕСЛИ(И(A1 3); «проходит», «не проходит»). Получается следующее условие: если оценка студента меньше или равна 5 и больше 3, то будет показан комментарий «проходит», в противном случае — «не проходит» (проходят только те студенты, у которых в оценках стоят четверки и пятерки).

    Более сложный пример использования функции ЕСЛИ — с использованием условий И либо ИЛИ

    Следующее условие с примером оператора ИЛИ: =ЕСЛИ(ИЛИ(A1=5; A1=10); 100; 0). Получается, что если число в ячейке А1 равняется 5 или 10, то программа выдаст 100, в противном случае — 0.

    Кроме того, можно применять эти простые операторы и для решения более сложных задач. Например, в базе данных необходимо отобрать должников, которые должны более 10 тысяч рублей и уже не платили более 6 месяцев. Если программа найдет такого человека, то пусть выдаст критерий «проблемный заемщик».

    Допустим, в ячейке A1 находится информация о сроке задолженности (в месяцах), а в поле B1 — сумма задолженности. Тогда формула будет выглядеть следующим образом: =ЕСЛИ(И(A1>=6; B1>10000); «проблемный заемщик»; «»). Если будет найден человек, который подходит под указанное условие, то программа напишет напротив его фамилии комментарий «проблемный заемщик», в противном случае ячейка останется пустой.

    Если один из параметров считается критическим, тогда можно составить формулу так: =ЕСЛИ(ИЛИ(A1>=6; B1>10000); «критическая ситуация»; «»). Если программа найдет совпадения хотя бы по одному параметру (либо срок, либо сумма задолженности), то пользователь увидит сообщение о том, что ситуация критическая. Разница с предыдущей формулой в том, что в первом случае сообщение «проблемный заемщик» выдавалось только тогда, когда выполнялись оба условия.

    Другие примеры использования оператора ЕСЛИ

    Функцию ЕСЛИ можно использовать для обхода встроенных ошибок деления на ноль, и еще в ряде случаев

    Очень часто в Экселе возникает такая ошибка, как «ДЕЛ/0», т.е. деление на 0. Как правило, она появляется в техслучаях, когда копируется формула «A/B», а число B в некоторых ячейках равняется нулю. Этого можно избежать, если использовать оператор ЕСЛИ. Для этого необходимо написать так: =ЕСЛИ(B1=0; 0; A1/B1). Получается, что если в ячейке B1 будет ноль, то Excel сразу же выдаст ноль, в противном случае программа поделит A1 на B1 и выдаст результат.

    Еще одна ситуация, которая довольно часто встречается на практике, расчет скидки в зависимости от общей суммы покупки. Для этого понадобится примерно такая матрица:

    • до 1000 — 0%;
    • от 1001 до 3000 — 3%;
    • от 3001 до 5000 — 5%;
    • свыше 5001 — 7%.

    К примеру, в Excel есть условная база данных клиентов и информация о том, сколько они потратили на покупки. Задача состоит в том, чтобы рассчитать для них скидку. Для этого можно написать так: =ЕСЛИ(A1>=5001; B1*0,93; ЕСЛИ(А1>=3001; B1*0,95;..). Суть ясна: проверяется общая сумма покупок, и когда она, к примеру, больше 5001 рублей, то умножается на 93% стоимости товара (ячейка B1*0,93), когда больше 3001 рублей, то умножается на 95% стоимости товара и т.д. Такую формулу легко можно использовать и на практике: уровень объема продаж и уровень скидок устанавливается на ваше усмотрение.

    Таким образом, применять функцию ЕСЛИ можно практически в любой ситуации, функциональность Microsoft Excel это позволяет. Главное — правильно составить формулу, чтобы результат не оказался ошибочным.

    Отблагодари меня, поделись ссылкой с друзьями в социальных сетях:

    Ссылка на основную публикацию
    ВсеИнструменты
    Adblock
    detector
    ×
    ×