Green-sell.info

Новые технологии
6 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Если больше или равно в excel

Логические функции Excel

Логические выражения используются для записи условий, в которых сравниваются числа, функции, формулы, текстовые или логические значения. Любое логическое выражение должно содержать по крайней мере один оператор сравнения, который определяет отношение между элементами логического выражения. Ниже представлен список операторов сравнения Excel

= Больше или равно

Результатом логического выражения является логическое значение ИСТИНА (1) или логическое значение ЛОЖЬ (0).

Функция ЕСЛИ

Функция ЕСЛИ (IF) имеет следующий синтаксис:

=ЕСЛИ(логическое_выражение;значение_если_истина;значение_если_ложь)

Следующая формула возвращает значение 10, если значение в ячейке А1 больше 3, а в противном случае — 20:

В качестве аргументов функции ЕСЛИ можно использовать другие функции. В функции ЕСЛИ можно использовать текстовые аргументы. Например:

=ЕСЛИ(А1>=4;»Зачет сдал»;»Зачет не сдал»)

Можно использовать текстовые аргументы в функции ЕСЛИ, чтобы при невыполнении условия она возвращала пустую строку вместо 0.

Аргумент логическое_выражение функции ЕСЛИ может содержать текстовое значение. Например:

Эта формула возвращает значение 10, если ячейка А1 содержит строку «Динамо», и 290, если в ней находится любое другое значение. Совпадение между сравниваемыми текстовыми значениями должно быть точным, но без учета регистра.

Функции И, ИЛИ, НЕ

Функции И (AND), ИЛИ (OR), НЕ (NOT) — позволяют создавать сложные логические выражения. Эти функции работают в сочетании с простыми операторами сравнения. Функции И и ИЛИ могут иметь до 30 логических аргументов и имеют синтаксис:

=И(логическое_значение1;логическое_значение2. )
=ИЛИ(логическое_значение1;логическое_значение2. )

Функция НЕ имеет только один аргумент и следующий синтаксис:

=НЕ(логическое_значение)

Аргументы функций И, ИЛИ, НЕ могут быть логическими выражениями, массивами или ссылками на ячейки, содержащие логические значения.

Приведем пример. Пусть Excel возвращает текст «Прошел», если ученик имеет средний балл более 4 (ячейка А2), и пропуск занятий меньше 3 (ячейка А3). Формула примет вид:

Если значение в ячейке А1 является целым числом, формула читается следующим образом: «Если значение в ячейке А1 равно 100, возвратить строку «Всегда». В противном случае, если значение в ячейке А1 находится между 80 и 100, возвратить «Обычно». В противном случае, если значение в ячейке А1 находится между 60 и 80, возвратить строку «Иногда». И, если ни одно из этих условий не выполняется, возвратить строку «Никогда». Всего допускается до 7 уровней вложения функций ЕСЛИ.

Функции ИСТИНА и ЛОЖЬ

Функции ИСТИНА (TRUE) и ЛОЖЬ (FALSE) предоставляют альтернативный способ записи логических значений ИСТИНА и ЛОЖЬ. Эти функции не имеют аргументов и выглядят следующим образом:

=ИСТИНА()
=ЛОЖЬ()

Например, ячейка А1 содержит логическое выражение. Тогда следующая функция возвратить значение «Проходите», если выражение в ячейке А1 имеет значение ИСТИНА:

В противном случае формула возвратит «Стоп».

Функция ЕПУСТО

Если нужно определить, является ли ячейка пустой, можно использовать функцию ЕПУСТО (ISBLANK), которая имеет следующий синтаксис:

=ЕПУСТО(значение)

Аргумент значение может быть ссылкой на ячейку или диапазон. Если значение ссылается на пустую ячейку или диапазон, функция возвращает логическое значение ИСТИНА, в противном случае ЛОЖЬ.

В начало страницы

В начало страницы

Если больше или равно в excel

Функция ЕСЛИ

​Смотрите также​ «СУММ» используется для​ цену в 2​ кругозора спасибО)))​Видео: усложненные функции ЕСЛИ​возвращает значение ИСТИНА;​=ЕСЛИ(И(B14>=$B$7,C14>=$B$5),B14*$B$8,0)​Аргумент​

​В Excel существуют логические​ Например, это функции​ с другими функциями.​ формулу.​

​ которое мы укажем​ двух аргументов или​Если у простой функции​ требуется изменять) не​ дополнительные вычисления в​Функция ЕСЛИ — одна из​

​ подсчета итогового балла.​ раза.​Владимир​Использование вложенных функций​ если он имеет​ —​Описание​ функции​

Технические подробности

​ ЕСЛИ, СЧЕТЕСЛИ, СУММЕСЛИ​=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B11;НАИМЕНЬШИЙ(ЕСЛИ($F$2=A2:A11;СТРОКА(B2:B11)-1;»»);​=ЕСЛИ(A4=»Да»;100;»»)​ в формуле. Можно​ значение ИСТИНА/ЛОЖЬ.​ ЕСЛИ есть только​

​ рекомендуется вводить прямо​

​ зависимости от условий.​

​ самых популярных функций​

​Функция ЕСЛИ позволяет решать​

​Сформируем таблицу с исходными​

​ значение ИСТИНА, функция​​ЕСЛИ​

​СТРОКА()-5));»»)​Обратите внимание!​​ выбрать любые числа,​​»#ИМЯ?» в ячейке​

​ два результата (ИСТИНА​​ в формулу, поскольку​

​ Для выполнения нескольких​ в Excel. Она​​ многочисленные задачи, поэтому​​ параметрами:​

Простые примеры функции ЕСЛИ

    ​Логические функции в Excel​

    ​Функция ЕСЛИ​НЕ​​общие продажи больше​Обязательный аргумент. Первое проверяемое​и​

      ​ логические условия можно​

      ​Эта формула для​В третьем условии​​ слова, т.д.​Как правило, это указывает​ и ЛОЖЬ), то​ в будущем их​

      ​ сравнений можно использовать​ позволяет выполнять логические​ используется чаще всего.​Чтобы решить поставленную задачу,​ проверяют данные и​Функция И​возвращает значение ЛОЖЬ.​ или равны (>=)​ условие, вычисление которого​ЛОЖЬ()​ задавать в обычных​ примера взята из​ в формуле мы​Появившееся диалоговое окно​ на ошибку в​ у вложенных функций​ может быть затруднительно​ несколько вложенных функций​ сравнения значений и​

      ​Задача 1. Проанализировать стоимость​​ воспользуемся логической функцией​ возвращают результат «ИСТИНА»,​Функция ИЛИ​Ниже представлено несколько общих​ целевым продажам​ дает значение ИСТИНА​, которые не имеют​

      Начало работы

      ​ формулах, если необходимо​ статьи «Выбрать сразу​ поставили не «нуль»,​ заполнили так.​ формуле.​ ЕСЛИ может быть​ найти и изменить.​ ЕСЛИ.​ ожидаемых результатов. Самая​ товарных остатков после​ ЕСЛИ. Формула будет​ если условие выполняется,​Полные сведения о​ примеров использования функции​И​ или ЛОЖЬ.​ аргументов. Данные функции​ получить утвердительный ответ:​ много данных из​ а две двойные​В формуле «ЕСЛИ» нужно​Видео: расширенное применение функции​ от 3 до​

      Еще примеры функции ЕСЛИ

      ​ Гораздо удобнее помещать​

      ​Примечание:​ простая функция ЕСЛИ​ уценки. Если цена​​ выглядеть так: =ЕСЛИ(C2>=8;B2/2;B2).​ и «ЛОЖЬ», если​ формулах в Excel​НЕ​число договоров больше​

      B2;C2-B2;»>

        ​ существуют в основном​Да​ таблицы Excel» здесь.​ кавычки – это​ написать три условия.​​ ЕСЛИ​ 64 результатов.​ константы в собственные​ Если вы используете текст​ означает следующее:​ продукта после переоценки​​Логическое выражение «С2>=8» построено​

          ​Рекомендации, позволяющие избежать​как отдельно, так​ или равно (>=)​​Необязательный аргумент. Дополнительные проверяемые​ для обеспечения совместимости​или​ Этой формулой выбираем​ значит «Пусто» (оставить​ В формуле эти​Функция ЕСЛИМН (Office 365, Excel 2016​=ЕСЛИ(D2=1;»ДА»;ЕСЛИ(D2=2;»Нет»;»Возможно»))​

          ​ ячейки, в которых​

          ​ в формулах, заключайте​ЕСЛИ(это истинно, то сделать​ ниже средних значений,​ с помощью операторов​Рассмотрим синтаксис логических функций​ появления неработающих формул​ и в сочетании​ целевому, общие продажи​ условия, вычисление которых​ с другими электронными​Нет​ из таблицы товара​ ячейку пустой). Скопировали​ условия напишутся через​ и более поздние​Показанная на рисунке выше​ они будут доступны​ его в кавычки​ это, в противном​ то списать со​ отношения «>» и​ и примеры применения​Поиск ошибок в​ с функциями​ умножаются на процент​ дает значение ИСТИНА​ таблицами. Вы можете​. К примеру, задавая​ и переносим в​ формулу в ячейку​ точку с запятой.​ версии)​

          Операторы вычислений

          ​ формула в ячейке​ и их можно​ (пример: «Текст»). Единственное​ случае сделать что-то​ склада этот продукт.​​ «=». Результат его​​ их в процессе​​ формулах​​ЕСЛИ​​ премии. В противном​​ или ЛОЖЬ. Условий​ вводить значения ИСТИНА​ простые логические условия,​ лист заказа выбранные​

          Читать еще:  Нумерация в excel 2020

          Использование функции ЕСЛИ для проверки ячейки на наличие символов

          ​ В5.​Первое условие –​Усложненные функции ЕСЛИ: как​ E2 означает:​ будет легко найти​ исключение — слова ИСТИНА​

          ​ еще)​Работаем с таблицей из​ вычисления – логическая​

          ​ работы с программой​

          ​Сочетания клавиш и​​,​ случае возвращается значение​ может быть не​ и ЛОЖЬ прямо​​ Вы можете ответить​ покупателем позиции.​Третий пример.​ «Лог_выражение». Мы написали​ работать с вложенными​ЕСЛИ(D2 равно 1, то​ и изменить. В​ и ЛОЖЬ, которые​

            ​Поэтому у функции ЕСЛИ​

            ​ предыдущего раздела:​​ величина «ИСТИНА» или​ Excel.​ горячие клавиши в​И​ 0.​​ более 255.​ в ячейки или​ на такие вопросы:​Ещё есть функция​В следующей формуле​ А1=2 – это​

            ​ формулами и избежать​

            ​ вернуть текст «Да»,​ нашем случае все​ Excel распознает автоматически.​ возможны два результата.​​Для решения задачи используем​

            Пример вложенных функций ЕСЛИ

            ​ «ЛОЖЬ». В первом​Название функции​ Excel​и​Видео: усложненные функции ЕСЛИ​Примечания​ формулы, не используя​5 больше 8?​

              ​ «СЧЁТЕСЛИ» в Excel​

              ​ поставили в третьем​ значит, если в​ ошибок​​ в противном случае​ в порядке, так​Прежде чем написать оператор​ Первый результат возвращается​ формулу вида: .​ случае функция возвращает​Значение​Сочетания клавиш в​​ИЛИ​Использование вложенных функций​Аргументы должны давать в​ форму записи функции,​Содержимое ячейки A5 меньше​ — она считает​ условии знак «Тире».​ ячейке А1 стоит​Обучающие видео: усложненные функции​ ЕСЛИ(D2 равно 2,​ как здесь используется​

              Небольшое предупреждение

              ​ ЕСЛИ, подумайте, чего​ в случае, если​ В логическом выражении​ значение «В2/2». Во​Синтаксис​ Excel 2016 для Mac​

              ​.​ в формуле​ результате логические значения​ Excel все прекрасно​ 8?​ количество ячеек по​ =ЕСЛИ(A5=»Да»;100;»-«)​ цифра 2. Мы​ ЕСЛИ​ то вернуть текст​ только одна функция​ вы хотите достичь.​ сравнение истинно, второй —​ «D2​ втором – «В2».​Примечание​Логические функции (ссылка)​

              ​Формула​Функция ЕСЛИ​ (такие как ИСТИНА​ поймет.​А может равно 8?​ нашим условиям. Смотрите​В ячейку В6​ написали условие, по​Подсчет значений на основе​ «Нет», в противном​

              ​ ЕСЛИ, а ставка​ Какое сравнение вы​ если сравнение ложно.​Задача 2. Найти средние​Усложним задачу – задействуем​ИСТИНА​Функции Excel (по​

              Распространенные неполадки

              ​Если Вы уверены, что​​В Excel имеется ряд​​ статью «Функция «СЧЁТЕСЛИ​​ написали такую формулу.​​ которому нужно искать​ одного условия с​ случае вернуть текст​ налога с продажи​

              ​ пытаетесь выполнить? Написать​

              ​Если вы ищете информацию​ продажи в магазинах​ логическую функцию И.​

              См. также

              ​Не имеет аргументов, возвращает​ алфавиту)​

              ​=НЕ(A2>100)​Функция НЕ​ быть массивами или​

              ​ уже достаточно хорошо​ стандартных операторов, которые​ в Excel». Эту​ =ЕСЛИ(A6=»%»;1;»нет») Здесь в​

              ​ ячейки в столбце​ помощью функции СЧЁТЕСЛИ​

              ​ «Возможно»)).​ будет редко изменяться.​ оператор ЕСЛИ не​

              ​ о работе с​ сети.​ Теперь условие такое:​

              ​ логическое значение «ИСТИНА».​Функции Excel (по​A2​

              ​Полные сведения о​ ссылками, содержащими логические​ освоили эту тему,​

              ​ используются для задания​

              ​ функция может посчитать​

              ​ третьем условии написали​

              ​ А (ячейки, в​Подсчет значений на основе​

              ​Обратите внимание на​ Даже если она​

              ​ сложнее, чем выстроить​ несколькими операторами ЕСЛИ,​Составим таблицу с исходными​

              ​ если товар хранится​

              Функция «ЕСЛИ» в Excel.

              Как задать простое логическое условие в Excel

              ​ с функцией​ все ли проверяемые​ в противном случае.​ Excel ячейки в​ С1 слово «Да».​ «6». Можно написать​ с помощью функции​Нужно очень крепко подумать,​ приоритеты.​=ЕСЛИ(C2>B2;»Превышение бюджета»;»В пределах бюджета»)​Имя аргумента​​ В9 – условие.​​ или продукт хранится​​ «ЛОЖЬ».​​ Как так сделать?​ значение ЛОЖЬ.​ убедиться, что одно​ЕСЛИ​

              • ​ условия принимают значение​
              • ​ Задавая такое условие,​ определенных строках».​
              • ​ Если число будет​

              Операторы сравнения в Excel

              ​ любое слово в​ проверки ошибок​ чтобы выстроить последовательность​Иногда требуется проверить, пуста​В примере выше функция​Описание​ Третий аргумент –​

              Как задать условие в Excel

              ​ дольше 10 месяцев,​=И (Лог_знач. 1; Лог_знач.​И скажить как​=ЕСЛИ(ИЛИ(НЕ(A350)); A3; «Значение вне​ значение не равно​.​

              ​ ИСТИНА.​​ можно сравнивать текстовые​Можно в Excel​ меньше 2, то​ этом условии, т.д.​Логические функции​ из множества операторов​ ли ячейка. Обычно​ ЕСЛИ в ячейке​лог_выражение​ $C$2:$C$7 – диапазон​ его списывают.​ 2;…)​ написать чтоб EXCEL​

              ​ интервала»)​​ другому.​Формула​Функция​ строки без учета​ суммировать данные из​ ячейка должна оставаться​Третье условие –​Функции Excel (по алфавиту)​ ЕСЛИ и обеспечить​ это делается, чтобы​

              ​ D2 означает:​ (обязательно)​ усреднения; числовые значения,​Для решения используем логические​Принимает до 255 аргументов​ понял что надо​100 не меньше 0​Функция​Описание​И​

              ​ регистра. К примеру,​ таблицы по многим​ пустой. Скопировали формулу​ «Значение_если_ложь» — здесь​Функции Excel (по категориям)​ их правильную отработку​ формула не выводила​

              ​ЕСЛИ(C2 больше B2, то​​Условие, которое нужно проверить.​ которые берутся для​ функции ЕСЛИ и​ в виде условий​ «Больше или равно»,»Меньше​ (ЛОЖЬ) и больше​

              ​НЕ​=И(A2>1;A2​​возвращает значение ИСТИНА,​​ сравнивая «ЯНВАРЬ» и​​ разным условиям. Например,​​ по столбцу С.​ мы напишем, что​Часто применяемая,​ по каждому условию​ результат при отсутствии​ вернуть текст «Превышение​значение_если_истина​ расчета среднего арифметического.​ ИЛИ: =10);»списан»;»»)’ class=’formula’>.​ или ссылок. Обязательным​ или равно», «Не​ чем 50 (ИСТИНА),​меняет значение своего​

              ​Возвращает значение ИСТИНА, если​ если в результате​ «январь» формула возвратит​ в функции «ЕСЛИ»​ Получилось так.​ нужно писать, если​логическая функция в Excel​ на протяжении всей​ входного значения.​ бюджета», в противном​​ (обязательно)​​Функция СРЗНАЧЕСЛИ сопоставляет значение​​ Условие, записанное с​​ является первый.​

              ​ ровняется». Так для​

              Функция И

              ​ поэтому функция​​ аргумента на обратное.​ число в ячейке​ вычисления всех аргументов​ ИСТИНА.​ можно написать одно​Пятый пример.​

              Пример

              Технические подробности

              ​ в ячейке А1​​ — функция «ЕСЛИ»​​ цепочки. Если при​В данном случае мы​ случае вернуть текст​Значение, которое должно возвращаться,​ ячейки В9 (№1)​ помощью логической операции​ИЛИ​ кругозора))))​НЕ​

              ​Обычно функция​​ A2 больше 1​​ получается значение ИСТИНА,​=A1>B1​ условие поиска данных​Можно функцией «ЕСЛИ»​​ будет написано НЕ​​считает данные ячеек​ вложении операторов ЕСЛИ​ используем ЕСЛИ вместе​ «В пределах бюджета»)​ если​ со значениями в​ ИЛИ, расшифровывается так:​Показывает результат «ИСТИНА», если​​Шит​​изменяет значения аргументов​​НЕ​​И​​ и значение ЛОЖЬ,​​— Следующая формула​ для суммирования. В​ посчитать итог теста,​

              ​ по условию, которое​​ вы допустите малейшую​

              ​ с функцией ЕПУСТО:​​=ЕСЛИ(C2>B2;C2-B2;0)​​лог_выражение​

              Условие больше или равно в excel

              Логические выражения используются для записи условий, в которых сравниваются числа, функции, формулы, текстовые или логические значения. Любое логическое выражение должно содержать по крайней мере один оператор сравнения, который определяет отношение между элементами логического выражения. Ниже представлен список операторов сравнения Excel

              = Больше или равно

              Результатом логического выражения является логическое значение ИСТИНА (1) или логическое значение ЛОЖЬ (0).

              Читать еще:  Невозможно создать структуру документа excel

              Функция ЕСЛИ

              Функция ЕСЛИ (IF) имеет следующий синтаксис:

              =ЕСЛИ(логическое_выражение;значение_если_истина;значение_если_ложь)

              Следующая формула возвращает значение 10, если значение в ячейке А1 больше 3, а в противном случае – 20:

              В качестве аргументов функции ЕСЛИ можно использовать другие функции. В функции ЕСЛИ можно использовать текстовые аргументы. Например:

              =ЕСЛИ(А1>=4;»Зачет сдал»;»Зачет не сдал»)

              Можно использовать текстовые аргументы в функции ЕСЛИ, чтобы при невыполнении условия она возвращала пустую строку вместо 0.

              Аргумент логическое_выражение функции ЕСЛИ может содержать текстовое значение. Например:

              Эта формула возвращает значение 10, если ячейка А1 содержит строку «Динамо», и 290, если в ней находится любое другое значение. Совпадение между сравниваемыми текстовыми значениями должно быть точным, но без учета регистра.

              Функции И, ИЛИ, НЕ

              Функции И (AND), ИЛИ (OR), НЕ (NOT) – позволяют создавать сложные логические выражения. Эти функции работают в сочетании с простыми операторами сравнения. Функции И и ИЛИ могут иметь до 30 логических аргументов и имеют синтаксис:

              =И(логическое_значение1;логическое_значение2. )
              =ИЛИ(логическое_значение1;логическое_значение2. )

              Функция НЕ имеет только один аргумент и следующий синтаксис:

              =НЕ(логическое_значение)

              Аргументы функций И, ИЛИ, НЕ могут быть логическими выражениями, массивами или ссылками на ячейки, содержащие логические значения.

              Приведем пример. Пусть Excel возвращает текст «Прошел», если ученик имеет средний балл более 4 (ячейка А2), и пропуск занятий меньше 3 (ячейка А3). Формула примет вид:

              Логическая функция ЕСЛИ в Экселе – одна из самых востребованных. Она возвращает результат (значение или другую формулу) в зависимости от условия.

              Функция ЕСЛИ в Excel

              Функция имеет следующий синтаксис.

              ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь])

              лог_выражение – это проверяемое условие. Например, A2 30) не выполняется и возвращается альтернативное значение, указанное в третьем поле. В этом вся суть функции ЕСЛИ. Протягивая расчет вниз, получаем результат по каждому товару.

              Однако это был демонстрационный пример. Чаще формулу Эксель ЕСЛИ используют для более сложных проверок. Допустим, есть средненедельные продажи товаров и их остатки на текущий момент. Закупщику нужно сделать прогноз остатков через 2 недели. Для этого нужно от текущих запасов отнять удвоенные средненедельные продажи.

              Пока все логично, но смущают минусы. Разве бывают отрицательные остатки? Нет, конечно. Запасы не могут быть ниже нуля. Чтобы прогноз был корректным, нужно отрицательные значения заменить нулями. Здесь отлично поможет формула ЕСЛИ. Она будет проверять полученное по прогнозу значение и если оно окажется меньше нуля, то принудительно выдаст ответ 0, в противном случае — результат расчета, т.е. некоторое положительное число. В общем, та же логика, только вместо значений используем формулу в качестве условия.

              В прогнозе запасов больше нет отрицательных значений, что в целом очень неплохо.

              Формулы Excel ЕСЛИ также активно используют в формулах массивов. Здесь мы не будем далеко углубляться. Заинтересованным рекомендую прочитать статью о том, как рассчитать максимальное и минимальное значение по условию. Правда, расчет в той статье более не актуален, т.к. в Excel 2016 появились функции МИНЕСЛИ и МАКСЕСЛИ. Но для примера очень полезно ознакомиться – пригодится в другой ситуации.

              Формула ЕСЛИ в Excel – примеры нескольких условий

              Довольно часто количество возможных условий не 2 (проверяемое и альтернативное), а 3, 4 и более. В этом случае также можно использовать функцию ЕСЛИ, но теперь ее придется вкладывать друг в друга, указывая все условия по очереди. Рассмотрим следующий пример.

              Нескольким менеджерам по продажам нужно начислить премию в зависимости от выполнения плана продаж. Система мотивации следующая. Если план выполнен менее, чем на 90%, то премия не полагается, если от 90% до 95% — премия 10%, от 95% до 100% — премия 20% и если план перевыполнен, то 30%. Как видно здесь 4 варианта. Чтобы их указать в одной формуле потребуется следующая логическая структура. Если выполняется первое условие, то наступает первый вариант, в противном случае, если выполняется второе условие, то наступает второй вариант, в противном случае если… и т.д. Количество условий может быть довольно большим. В конце формулы указывается последний альтернативный вариант, для которого не выполняется ни одно из перечисленных ранее условий (как третье поле в обычной формуле ЕСЛИ). В итоге формула имеет следующий вид.

              Комбинация функций ЕСЛИ работает так, что при выполнении какого-либо указанно условия следующие уже не проверяются. Поэтому важно их указать в правильной последовательности. Если бы мы начали проверку с B2 =1. Однако этого можно избежать, если в поле с условием написать ИСТИНА, указывая тем самым, что, если не выполняются ранее перечисленные условия, наступает ИСТИНА и возвращается последнее альтернативное значение.

              Теперь вы знаете, как пользоваться функцией ЕСЛИ в Excel, а также ее более современным вариантом для множества условий ЕСЛИМН.

              Такие выражения, как «больше или равно», «меньше или равно» и «не равно», могут быть очень полезны при анализе данных.

              Эти операторы используют сравнения двух значени й, и результатом сравнения будет ИСТИНА или ЛОЖЬ.

              Обратите внимание, что логические операторы сравнивают значения независимо от того, было ли оно введено напрямую или было создано с помощью формулы. Эти операторы сравнивают именно значения. Не формулы.

              Равно (=) и не равно (<>)

              Эти операторы просты: они говорят вам, являются ли два значения равными или не равными друг другу:

              Эти операторы равно и не равно также работают с текстом:

              Больше (>) и меньше (

              Эти два оператора сравнивают размер двух разных значений и возвращают ИСТИНА или ЛОЖЬ в зависимости от того, что больше:

              Оператор больше (>) – если первое значение больше второго, результатом будет ИСТИНА

              Оператор меньше ( Больше или равно (> =) и меньше или равно (

              Оператор больше или равно (> =) – если первое значение больше второго или равно ему, результатом будет ИСТИНА

              Функция ЕСЛИ (IF) в Excel — правила использования, примеры

              Функция ЕСЛИ() применяется для выборки значения (-ий) по заданному условию (-ий). Аргументы функции:

              Аргумент Лог_выражение применяется для записи непосредственно условия поиска. Возвращает логические значения «истина» или «ложь». Для формирования условия, значения можно брать как из ячеек, так и записывать непосредственно в формуле.

              Два остальных аргумента — для вывода значения, если первый аргумент вывел «истину» и второй если вывел «ложь».

              Например, требуется сравнить два значения и вывести в ячейке большее значение. Синтаксис формулы такой:

              =ЕСЛИ(B2>C2;B2;C2) – читается так, если значение B2 больше C2 выводим B2, иначе C2:

              Тоже самое можно сделать для разных форматов, например, для текста:

              В этом примере я проверяю значение ячейки B4 и если там слово «яблоко» (написано непосредственно в строке условия, в двойных кавычках), то показать слово «фрукт». Аргументы если «истина» и, если «ложь» являются не обязательными, в случае их отсутствия, при выполнения условия будет выводиться слово «истина» или слово «ложь».

              Читать еще:  Как сделать уровни в excel

              В моем примере, если написать в B4 любое другое слово программа скажет:

              Примеры функции ЕСЛИ(IF) с несколькими условиями.

              Часто бывает, что необходимо использовать два и более условия. Для решения этой задачи мы будем вкладывать функцию в функцию.

              Возьмем предыдущий пример, и напишем дополнительное условие для слова груши:

              Читается так: если B4 равно «яблоко», то выводим слово «фрукт», иначе (выполняем следующую функцию ЕСЛИ) если B4 равно «груша», то выводим слово «фрукт», иначе выводим «не фрукт».

              Таких вложений может быть до 64!

              Функция ЕСЛИ() выполняет условия строго по порядку и завершает свою работу, если условие было выполнено.

              Это очень важное замечание в использовании формулы его необходимо учитывать. Приведу пример поломанной логики:

              У нас есть таблица фруктов с количеством и себестоимостью, а нам надо определить исходя из себестоимости, нашу наценку для получения итоговой цены. Также у нас есть таблица наценок, которые зависят от себестоимости фрукта:

              Применяем такую формулу:

              и протягиваем ее:

              Получаем 10% для всех значений. Формула начинается работу с первого аргумента – он возвращает истину, и формула завершает свою работу.

              Здесь спасти положение может только добавление в функцию ЕСЛИ() функцию И(), для проверки в каком диапазоне находится себестоимость, и какую наценку надо выводить:

              Примеры использования функции ЕСЛИ()

              Заменим в предыдущем примере столбец наценка на столбец цена и будем выводить сразу итоговую цену. Формула примет следующий вид:

              Главное не запутаться в скобках . Протягиваем формулу:

              На этом все, если у вас есть вопросы оставляйте в комментариях.

              ITGuides.ru

              Вопросы и ответы в сфере it технологий и настройке ПК

              Примеры использования функции проверки условия (ЕСЛИ) в Excel

              Функция ЕСЛИ относится к логическим функциям Microsoft Excel и является одной из наиболее часто используемых в работе. С помощью этого оператора можно выполнять различные задачи, когда необходимо сравнить какие-то данные и выдать результат. Функция ЕСЛИ в Excel дает возможность использовать в работе ветвящиеся алгоритмы, строить дерево решений и т.д.

              Видео по использованию функции ЕСЛИ в Excel

              Примеры использования оператора ЕСЛИ

              Функция ЕСЛИ выглядит следующим образом:

              =ЕСЛИ (выражение; истина; ложь).

              А теперь немного подробнее:

              1. Выражение — это логическое выражение, которое может быть числом или фразой. Например «10» — это логическое выражение, «без НДС» — тоже логическое выражение. Это единственный параметр, который заполняется в обязательном порядке.
              2. Истина — значение, которое будет выдано в качестве результата, если выражение окажется истинным.
              3. Ложь — значение, которое будет выдано, если выражение будет ложным.

              Простейший пример реализации функции ЕСЛИ в Excel — проверяем равенство значений двух ячеек

              К примеру, можно ввести в поле C1 цифру 8, а в поле D1 написать так: =ЕСЛИ(C1 );

            • меньше ( =);
            • меньше или равно ( ).
            • Примеры функций И, ИЛИ

              Также при использовании в Экселе функции ЕСЛИ есть возможность соединить ее с простыми операторами сравнения (вроде И, ИЛИ). Например, можно написать такое условие: =ЕСЛИ(И(A1 3); «проходит», «не проходит»). Получается следующее условие: если оценка студента меньше или равна 5 и больше 3, то будет показан комментарий «проходит», в противном случае — «не проходит» (проходят только те студенты, у которых в оценках стоят четверки и пятерки).

              Более сложный пример использования функции ЕСЛИ — с использованием условий И либо ИЛИ

              Следующее условие с примером оператора ИЛИ: =ЕСЛИ(ИЛИ(A1=5; A1=10); 100; 0). Получается, что если число в ячейке А1 равняется 5 или 10, то программа выдаст 100, в противном случае — 0.

              Кроме того, можно применять эти простые операторы и для решения более сложных задач. Например, в базе данных необходимо отобрать должников, которые должны более 10 тысяч рублей и уже не платили более 6 месяцев. Если программа найдет такого человека, то пусть выдаст критерий «проблемный заемщик».

              Допустим, в ячейке A1 находится информация о сроке задолженности (в месяцах), а в поле B1 — сумма задолженности. Тогда формула будет выглядеть следующим образом: =ЕСЛИ(И(A1>=6; B1>10000); «проблемный заемщик»; «»). Если будет найден человек, который подходит под указанное условие, то программа напишет напротив его фамилии комментарий «проблемный заемщик», в противном случае ячейка останется пустой.

              Если один из параметров считается критическим, тогда можно составить формулу так: =ЕСЛИ(ИЛИ(A1>=6; B1>10000); «критическая ситуация»; «»). Если программа найдет совпадения хотя бы по одному параметру (либо срок, либо сумма задолженности), то пользователь увидит сообщение о том, что ситуация критическая. Разница с предыдущей формулой в том, что в первом случае сообщение «проблемный заемщик» выдавалось только тогда, когда выполнялись оба условия.

              Другие примеры использования оператора ЕСЛИ

              Функцию ЕСЛИ можно использовать для обхода встроенных ошибок деления на ноль, и еще в ряде случаев

              Очень часто в Экселе возникает такая ошибка, как «ДЕЛ/0», т.е. деление на 0. Как правило, она появляется в техслучаях, когда копируется формула «A/B», а число B в некоторых ячейках равняется нулю. Этого можно избежать, если использовать оператор ЕСЛИ. Для этого необходимо написать так: =ЕСЛИ(B1=0; 0; A1/B1). Получается, что если в ячейке B1 будет ноль, то Excel сразу же выдаст ноль, в противном случае программа поделит A1 на B1 и выдаст результат.

              Еще одна ситуация, которая довольно часто встречается на практике, расчет скидки в зависимости от общей суммы покупки. Для этого понадобится примерно такая матрица:

              • до 1000 — 0%;
              • от 1001 до 3000 — 3%;
              • от 3001 до 5000 — 5%;
              • свыше 5001 — 7%.

              К примеру, в Excel есть условная база данных клиентов и информация о том, сколько они потратили на покупки. Задача состоит в том, чтобы рассчитать для них скидку. Для этого можно написать так: =ЕСЛИ(A1>=5001; B1*0,93; ЕСЛИ(А1>=3001; B1*0,95;..). Суть ясна: проверяется общая сумма покупок, и когда она, к примеру, больше 5001 рублей, то умножается на 93% стоимости товара (ячейка B1*0,93), когда больше 3001 рублей, то умножается на 95% стоимости товара и т.д. Такую формулу легко можно использовать и на практике: уровень объема продаж и уровень скидок устанавливается на ваше усмотрение.

              Таким образом, применять функцию ЕСЛИ можно практически в любой ситуации, функциональность Microsoft Excel это позволяет. Главное — правильно составить формулу, чтобы результат не оказался ошибочным.

              Отблагодари меня, поделись ссылкой с друзьями в социальных сетях:

              Ссылка на основную публикацию
              ВсеИнструменты
              Adblock
              detector